Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17743

jenkins fails to start (even on clean config)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Won't Fix
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Upgraded jenkins, it doesn't start anymore.

      Even if i try to remove its directory, it recreates it cleanly but then crashes with following log.

      I tried every version from 1.417 to 1.421. They do work. I tried various versions from 1.422 to 1.512, they all crash with the same symptoms.

      [#|2013-04-24T07:24:49.849+0200|INFO|glassfish3.1.2|javax.enterprise.system.tools.admin.org.glassfish.deployment.admin|_ThreadID=106;_ThreadName=Thread-2;|jenkins was successfully deployed in 3,800 milliseconds.|#]

      [#|2013-04-24T07:24:50.100+0200|INFO|glassfish3.1.2|jenkins.InitReactorRunner|_ThreadID=152;_ThreadName=Thread-2;|Listed all plugins|#]

      [#|2013-04-24T07:24:50.100+0200|SEVERE|glassfish3.1.2|jenkins.InitReactorRunner|_ThreadID=152;_ThreadName=Thread-2;|Failed Loading plugins
      java.lang.NullPointerException
      at hudson.PluginManager$2$1.run(PluginManager.java:324)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:888)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:722)

      #]

      [#|2013-04-24T07:24:50.102+0200|SEVERE|glassfish3.1.2|hudson.WebAppMain|_ThreadID=143;_ThreadName=Thread-2;|Failed to initialize Jenkins
      org.jvnet.hudson.reactor.ReactorException: java.lang.NullPointerException
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:246)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:43)
      at jenkins.model.Jenkins.executeReactor(Jenkins.java:899)
      at jenkins.model.Jenkins.<init>(Jenkins.java:801)
      at hudson.model.Hudson.<init>(Hudson.java:81)
      at hudson.model.Hudson.<init>(Hudson.java:77)
      at hudson.WebAppMain$2.run(WebAppMain.java:214)
      Caused by: java.lang.NullPointerException
      at hudson.PluginManager$2$1.run(PluginManager.java:324)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:888)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:722)

      #]

      Jenkins is running on Glassfish 3.1.2.2 on a ubuntu 12.04 server.

      Posted on http://stackoverflow.com/questions/16184035/cannot-run-jenkins-even-after-clearing-its-directory

        Attachments

          Activity

          ymajoros ymajoros added a comment -

          Still the same with 1.519. Can anyone give me a hint where to look?

          ymajoros ymajoros added a comment -

          Found this, and I had 2 virtual servers.

          https://gist.github.com/andrewg4153/3693577
          If you have a Glassfish domain with multiple virtual servers, you will be tempted to select them all when you deploy the Jenkins CI web application. This is a bad thing to do, as the Jenkins core code contains a singleton class: http://sorcerer.jenkins-ci.org/source-view.html?jenkins/model/Jenkins.js#678 When you do this, you'll get the following in your logs:

          java.lang.IllegalStateException: second instance
          at jenkins.model.Jenkins.<init>(Jenkins.java:744)
          at hudson.model.Hudson.<init>(Hudson.java:81)
          at hudson.model.Hudson.<init>(Hudson.java:77)
          at hudson.WebAppMain$2.run(WebAppMain.java:217)

          Just deploy to one of the virtual servers, and everything will be okay.

          I deployed on 1 of them and it now works!

          Well, I guess it's the bug to fix...

          danielbeck Daniel Beck added a comment -

          Jenkins obviously doesn't support this (and it seems from the comment that Jenkins reports a fairly useful error message).

          danielbeck Daniel Beck added a comment -

          Sorry, wrong solution.


            People

            • Assignee:
              Unassigned
              Reporter:
              ymajoros ymajoros
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: