Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17859

TAP report table show failed test message on ALL tests after the failed one.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: tap-plugin
    • Labels:
      None
    • Environment:
      Jenkins: Ubuntu 13
      Slave: Ubuntu 11, phpunit, tap report
    • Similar Issues:

      Description

      Tap Plugin add failed test data to ALL successful tests after the failed one.
      Tap Example:
      ok 42 - S::test_1
      ok 43 - S::test_2
      not ok 44 - Failure: test_3

      message: 'Failed asserting that Y matches expected X.'
      severity: fail
      data:
      got: Y
      expected: X
      ...
      ok 45 - S::test_4
      ok 46 - S::test_5
      ok 47 - S::test_6
      ok 48 - S::test_7

        Attachments

          Activity

          kinow Bruno P. Kinoshita added a comment -

          Hi Moshe, thanks for reporting. I intend to rewrite the whole custom UI in tap-plugin. At moment it's using some old Jelly that I wrote while quickly-prototyping the plug-in idea. I want to migrate it to groovy and use more Jenkins built-in code, rather than reinventing the wheel. Will try to cut a new release by the next weekend or the next week or so.

          kinow Bruno P. Kinoshita added a comment -

          Hi again Moshe. Just confirmed it was a critical bug in tap4j [1].

          Fixed in [2]. Will cut a new release of tap4j tonight, as well as a new tap-plugin version tonight or tomorrow morning (since it

          [1] https://github.com/tupilabs/tap4j/issues/14
          [2] https://github.com/tupilabs/tap4j/commit/196088760ef63443aea444f750a613b41e3f1733

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Bruno P. Kinoshita
          Path:
          pom.xml
          http://jenkins-ci.org/commit/tap-plugin/ceeaf88dda9e79dbb1852890e4baae067598d4ea
          Log:
          [FIXED JENKINS-17859] Fix tabs in pom.xml and bump tap4j to 4.0.3

          kinow Bruno P. Kinoshita added a comment -

          Fixed in 1.11 (should be available through the update site in the next minute/hours)


            People

            • Assignee:
              kinow Bruno P. Kinoshita
              Reporter:
              mbelosto Moshe Belostotsky
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: