Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18351

Fingerprinting seems to leak Files

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      jenkins 1.5.18; debian squeeze; jenkins package
    • Similar Issues:

      Description

      When fingerprinting large projects, jenkins fails with the following error message:

      Recording fingerprints
      ERROR: Failed to record fingerprints
      hudson.util.IOException2: Failed to compute digest for /var/lib/jenkins/workspace/zetbox-develop-Linux-Build-3-0/packages/NHibernate-dasz.3.3.3-DASZ2/src/Cfg/MappingSchema/HbmProperty.cs
      	at hudson.tasks.Fingerprinter$2.invoke(Fingerprinter.java:243)
      	at hudson.tasks.Fingerprinter$2.invoke(Fingerprinter.java:225)
      	at hudson.FilePath.act(FilePath.java:905)
      	at hudson.FilePath.act(FilePath.java:878)
      	at hudson.tasks.Fingerprinter.record(Fingerprinter.java:225)
      	at hudson.tasks.Fingerprinter.perform(Fingerprinter.java:121)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:776)
      	at hudson.model.Build$BuildExecution.post2(Build.java:183)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:726)
      	at hudson.model.Run.execute(Run.java:1601)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:241)
      Caused by: java.io.FileNotFoundException: /var/lib/jenkins/workspace/zetbox-develop-Linux-Build-3-0/packages/NHibernate-dasz.3.3.3-DASZ2/src/Cfg/MappingSchema/HbmProperty.cs (Too many open files)
      	at java.io.FileInputStream.open(Native Method)
      	at java.io.FileInputStream.<init>(FileInputStream.java:137)
      	at hudson.FilePath$30.invoke(FilePath.java:1667)
      	at hudson.FilePath$30.invoke(FilePath.java:1664)
      	at hudson.FilePath.act(FilePath.java:905)
      	at hudson.FilePath.act(FilePath.java:878)
      	at hudson.FilePath.digest(FilePath.java:1664)
      	at hudson.tasks.Fingerprinter$2.invoke(Fingerprinter.java:241)
      	... 14 more
      Build step 'Record fingerprints of files to track usage' changed build result to FAILURE
      Finished: FAILURE
      

        Attachments

          Issue Links

            Activity

            jmccaske Jim McCaskey added a comment -

            @brian3791 would probably need to confirm, but I'm still have the MOJO-1941 problem on 1.524.

            brian3791 Brian Brooks added a comment -

            @Jim that's odd. After upgrading to 1.523 my MOJO-1941 issue was resolved. No more maven artifact file locks caused by hudson.maven.reporters.MavenFingerprinter.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            core/src/main/java/hudson/model/DirectoryBrowserSupport.java
            http://jenkins-ci.org/commit/jenkins/2ea0276e7b4ea9614961a530382320c49ab626a2
            Log:
            [CID-1205053] - Resource leak on fingerprint calculation in DirectoryBrowserSupport

            The issue is related to JENKINS-18351.

            Signed-off-by: Oleg Nenashev <o.v.nenashev@gmail.com>

            jglick Jesse Glick added a comment -

            https://github.com/jenkinsci/jenkins/pull/1434 may fix another issue here, not sure.

            krw1243 Kelsey Prantis added a comment -

            We're seeing an issue with the exact same output. Unfortunately, we are still on Jenkins 1.498 and upgrading right now isn't an option. But looking at the link of where this regressed, it looks like the earliest tag I see is 1.517 - am I reading correctly that this bug wasn't introduced until then so we should be looking elsewhere as to the source of our issue?

            If it is this issue, is there anything we can do on the system running Jenkins to try to mitigate it?


              People

              • Assignee:
                jglick Jesse Glick
                Reporter:
                davidschmitt David Schmitt
              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: