Details

    • Type: Patch
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: dry-plugin, pmd-plugin
    • Labels:
      None
    • Environment:
      trying to parse a simian xml log report with latest jenkins/DRY copy paste detector.
      Simian version: 2.3.34
    • Similar Issues:

      Description

      trying to parse a simian xml log report with latest jenkins/DRY copy paste detector.

      the output is the following :
      [DRY] Parsing of file C:\JenkinsTFS\simian.xml failed due to an exception:

      java.io.IOException: No parser found for duplicated code results file C:\JenkinsTFS\simian.xml
      at hudson.plugins.dry.parser.DuplicationParserRegistry.parse(DuplicationParserRegistry.java:102)
      at hudson.plugins.analysis.core.FilesParser.parseFile(FilesParser.java:306)
      at hudson.plugins.analysis.core.FilesParser.parseFiles(FilesParser.java:264)
      at hudson.plugins.analysis.core.FilesParser.parserCollectionOfFiles(FilesParser.java:215)
      at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:184)
      at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:31)
      at hudson.FilePath.act(FilePath.java:905)
      at hudson.FilePath.act(FilePath.java:878)
      at hudson.plugins.dry.DryPublisher.perform(DryPublisher.java:175)
      at hudson.plugins.analysis.core.HealthAwarePublisher.perform(HealthAwarePublisher.java:146)
      at hudson.plugins.analysis.core.HealthAwareRecorder.perform(HealthAwareRecorder.java:331)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:776)
      at hudson.model.Build$BuildExecution.post2(Build.java:183)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:726)
      at hudson.model.Run.execute(Run.java:1618)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:242)

        Attachments

        1. simian.xml
          3.76 MB
          pernes olivier

          Activity

          drulli Ulli Hafner added a comment -

          Seems that you file does not contain valid UTF-8 characters:

          Caused by: org.apache.xerces.impl.io.MalformedByteSequenceException: Invalid byte 2 of 3-byte UTF-8 sequence.
          	at org.apache.xerces.impl.io.UTF8Reader.invalidByte(Unknown Source)
          	at org.apache.xerces.impl.io.UTF8Reader.read(Unknown Source)
          	at org.apache.xerces.impl.XMLEntityScanner.load(Unknown Source)
          	at org.apache.xerces.impl.XMLEntityScanner.scanLiteral(Unknown Source)
          	at org.apache.xerces.impl.XMLScanner.scanAttributeValue(Unknown Source)
          	at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanAttribute(Unknown Source)
          	at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanStartElement(Unknown Source)
          
          

          Can you please check if Simian is able to produce valid UTF-8 sequences? The directory names seem to conain some accents.

          opernes pernes olivier added a comment -

          Hi, thanks for the answer.

          I checked this morning, and i did not find any options in Simian to output UTF8
          This might be the issue, as we do have accents in our paths(french company / code)

          would it be easy to parse this ?

          thanks in advance,

          drulli Ulli Hafner added a comment -

          I don't see anything that I can do here, this needs to be fixed in Simian. Can you open your file in an XML editor and validate the document?


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              opernes pernes olivier
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: