Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18591

CVS-Plugin sporadically fails to connect via SSH

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cvs-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      We see seemingly random connection failures:

      FATAL: CVS authentication failure while running rlog command
      java.lang.RuntimeException: CVS authentication failure while running rlog command
      at hudson.scm.AbstractCvs.getRemoteLogForModule(AbstractCvs.java:630)
      at hudson.scm.AbstractCvs.calculateChangeLog(AbstractCvs.java:696)
      at hudson.scm.AbstractCvs.postCheckout(AbstractCvs.java:715)
      at hudson.scm.CVSSCM.checkout(CVSSCM.java:359)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1367)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:674)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:579)
      at hudson.model.Run.execute(Run.java:1575)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:237)
      Caused by: org.netbeans.lib.cvsclient.connection.AuthenticationException: SSH connection failed.
      at org.netbeans.lib.cvsclient.connection.SSHConnection.open(SSHConnection.java:141)
      at org.netbeans.lib.cvsclient.Client$1.run(Client.java:374)
      at java.lang.Thread.run(Thread.java:722)
      Caused by: com.jcraft.jsch.JSchException: verify: false
      at com.jcraft.jsch.Session.connect(Session.java:307)
      at com.jcraft.jsch.Session.connect(Session.java:160)
      at org.netbeans.lib.cvsclient.connection.SSHConnection.open(SSHConnection.java:139)
      ... 2 more

      There is a (fixed in 1.50) jsch bug, which seems related. I updated our Jsch yesterday and since then no more connection errors occurred (Before it occurred at least a few times a day, so I'm pretty confident that 1.50 fixed the issue).

        Attachments

          Activity

          saschavogt Sascha Vogt created issue -
          scm_issue_link SCM/JIRA link daemon made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 149901 ] JNJira + In-Review [ 193341 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              saschavogt Sascha Vogt
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: