Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18843

Jenkins Wiping out workspace hudson.util.IOException2: remote file operation failed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: git-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      Hi
      we get frequently an error like this on our jobs on jenkins slaves:
      Wiping out workspace first.
      hudson.util.IOException2: remote file operation failed: <http://10.66.180.27:8080/job/Integration%20Flow%20Designtime%20Gerrit%20Voter/ws/> at hudson.remoting.Channel@44250147:Avt_veavjen007_Orange
      at hudson.FilePath.act(FilePath.java:900)
      at hudson.FilePath.act(FilePath.java:877)
      at hudson.plugins.git.GitSCM.determineRevisionToBuild(GitSCM.java:942)
      at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1108)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1369)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:676)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:581)
      at hudson.model.Run.execute(Run.java:1575)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:241)
      Caused by: java.io.IOException: Unable to delete <http://10.66.180.27:8080/job/Integration%20Flow%20Designtime%20Gerrit%20Voter/ws/.git\objects\pack\pack-c0af26544495cb6c77a6901bd276613f26e4c5a6.pack>
      at hudson.Util.deleteFile(Util.java:256)
      at hudson.Util.deleteRecursive(Util.java:308)
      at hudson.Util.deleteContentsRecursive(Util.java:205
      Our infrastructure consist of a Jenkins Master on Linux and slaves on Windows 2008 R2 Servers
      Attached you will find a screenshot of the task manager on the affected windows slave. Many ssh.exe, git.exe and some java.exe process run but should not run after a job is finished. What can we do to make jenkins killing the hanging processes?
      To fix this problem we tried one of the solution provide from the jenkins help page : https://issues.jenkins-ci.org/browse/JENKINS-15103 , included the parameter "-Dorg.jenkinsci.plugins.gitclient.Git.useCLI=true" in the JVM options for the slave but it does not help.
      Could you please help us
      Best regards,
      Peter

        Attachments

          Issue Links

            Activity

            markewaite Mark Waite added a comment -

            JENKINS-19994 includes more comments than this bug report, so I'm marking this one as a duplicate even though this was submitted before JENKINS-19994


              People

              • Assignee:
                ndeloof Nicolas De Loof
                Reporter:
                goebelp Peter Goebel
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: