Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18849

java.lang.ClassNotFoundException: hudson.maven.AbstractMavenProject

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Incomplete
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      RHEL
    • Similar Issues:

      Description

      I upgraded to 1.509.2. Now, the post build actions of the configure page is not displaying and giving an error 500. The Jenkins log is full of java.lang.ClassNotFoundException: hudson.maven.AbstractMavenProject.

      Screen shots and logs attached

      NOTE: I downgraded back to 1.509.1 but the error still exists.

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Oleg: Actually, cause is a until just now undocumented change to plugin dependency loading in 1.524. The original of issues like this one is probably JENKINS-18922.

            oleg_nenashev Oleg Nenashev added a comment -

            According to JENKINS-18654, the fix has been backported to 1.509.3, but the issue has been submitted to 1.509.2-

            danielbeck Daniel Beck added a comment -

            Right, I checked this issue in more detail and they're only superficially the same: Due to IO problems of some kind it failed to extract the Maven Plugin (and possibly Monitor External Job), so it's not just disabled, but missing completely. The effect is the same as with a disabled plugin post-1.524.

            Fix the logged IO root cause (e.g. missing permissions), possibly deleting maven-plugin.jpi and the issue should disappear.


            More information is needed to investigate this further, like the permissions inside the plugins directory, what kind of file system, etc.

            jglick Jesse Glick added a comment -

            Is this not just a duplicate of JENKINS-18922?

            danielbeck Daniel Beck added a comment -

            Jesse: See my previous comment. They look similar but this is a version from before the 1.524 fix or backport.

            Despite that, resolving as incomplete, as there has been no response to my comment asking for additional information.


              People

              • Assignee:
                Unassigned
                Reporter:
                hoohaa8384 Joshua Slominski
              • Votes:
                2 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: