Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19086

NullPointerException on ProcStarter.envs (Launcher.java:302)

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Master running on GNU/Linux Debian Wheezy (7.0)
      Slave running on Microsoft Windows XP SP3
      Oracle Java 7 / Maven 3.0.5
    • Similar Issues:

      Description

      I am using the Cloudbees Custom tools plugin, and since version 1.525 I get the following stack :

      FATAL: null
      java.lang.NullPointerException
      at hudson.Launcher$ProcStarter.envs(Launcher.java:302)
      at com.cloudbees.jenkins.plugins.customtools.CustomToolInstallWrapper$2.launch(CustomToolInstallWrapper.java:186)
      at hudson.Launcher$ProcStarter.start(Launcher.java:353)
      at com.netceler.ivpower.integrationtest.utils.CommandLauncher.launchCommand(CommandLauncher.java:25)
      at com.netceler.ivpower.integrationtest.install.InstallerLauncher.launchInstaller(InstallerLauncher.java:44)
      at com.netceler.ivpower.integrationtest.install.InstallBuildWrapper.setUp(InstallBuildWrapper.java:106)
      at hudson.model.Build$BuildExecution.doRun(Build.java:154)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:586)
      at hudson.model.Run.execute(Run.java:1593)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:247)

      I temporarly fixed the problem by adding a catch on NullPointerException on the Cloudbees plugin, but I think that the core itself should handle this case.

        Attachments

          Issue Links

            Activity

            Hide
            integer Kanstantsin Shautsou added a comment -

            What plugin version do you use?
            Also, this looks like a plugin's problem, not a "core" (jenkins itself).

            Show
            integer Kanstantsin Shautsou added a comment - What plugin version do you use? Also, this looks like a plugin's problem, not a "core" (jenkins itself).
            Hide
            falcon benoit guerin added a comment -

            for the custom-tools plugin version : the latest one, 0.3

            and I submit this on the core because I think doing a "envs.clone();" while envs could be null is not a great idea ...

            Show
            falcon benoit guerin added a comment - for the custom-tools plugin version : the latest one, 0.3 and I submit this on the core because I think doing a "envs.clone();" while envs could be null is not a great idea ...
            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            Issue is duplicated.
            custom-tools-1.4.1 will contain a fix for the issue

            Show
            oleg_nenashev Oleg Nenashev added a comment - Issue is duplicated. custom-tools-1.4.1 will contain a fix for the issue
            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            I've also added a link to the core

            Show
            oleg_nenashev Oleg Nenashev added a comment - I've also added a link to the core

              People

              • Assignee:
                Unassigned
                Reporter:
                falcon benoit guerin
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: