Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19135

unselected all nodes from multi-configuration result in configSubmit error

    Details

    • Similar Issues:

      Description

      to reproduce :

      • create a multi-configuration job, use slave axe
      • unselect "master" (sole node) from axe
      • save job configuration

      =>
      Failed to instantiate class hudson.matrix.LabelAxis from

      {"kind":"hudson.matrix.LabelAxis","name":"label","stapler-class":"hudson.matrix.LabelAxis"}

      "values" is missing from JSON data.
      For sure, disabling all nodes from slave-axe don't make much sense, but this error is confusing for user.

        Attachments

          Activity

          ndeloof Nicolas De Loof created issue -
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Jesse Glick
          Path:
          changelog.html
          core/src/main/java/hudson/matrix/Axis.java
          core/src/main/java/hudson/matrix/Layouter.java
          http://jenkins-ci.org/commit/jenkins/58c8a9393fbe31e4533343229603cae47723cc6e
          Log:
          [FIXED JENKINS-19135] Permit a user to configure an axis with no values without throwing exceptions.
          The project cannot be usefully built in this case but at least they can go back and reconfigure it.
          Also fixing Layouter.Column to not throw NoSuchElementException (in violation of Iterator contract)
          and thus break project overview when there is an empty Axis in the trivial list (due to an unintentional IndexOutOfBoundsException).

          scm_issue_link SCM/JIRA link daemon made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          dogfood dogfood added a comment -

          Integrated in jenkins_main_trunk #2811
          [FIXED JENKINS-19135] Permit a user to configure an axis with no values without throwing exceptions. (Revision 58c8a9393fbe31e4533343229603cae47723cc6e)

          Result = SUCCESS
          Jesse Glick : 58c8a9393fbe31e4533343229603cae47723cc6e
          Files :

          • core/src/main/java/hudson/matrix/Layouter.java
          • core/src/main/java/hudson/matrix/Axis.java
          • changelog.html
          danielbeck Daniel Beck made changes -
          Labels lts-candidate
          olivergondza Oliver Gond┼ża made changes -
          Labels lts-candidate 1.509.4-rejected
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 150582 ] JNJira + In-Review [ 193589 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              ndeloof Nicolas De Loof
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: