Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19143

Edit view => include jobs by regex broken, always "on"

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      core 1.526
    • Similar Issues:

      Description

      • Click hyperlink "Edit View" (URL /view/name/configure)
      • Select checkbox "Use a regular expression to include jobs into the view"
      • Enter a suitable regex in the text box "Regular expression" below
      • Click button "OK" to save
      • Now typically the view shows no jobs at all.
      • Click "Edit View" again
      • Notice your regex is replaced by "on"

      Strange bug...

      Workaround:

      • Open $JENKINS_HOME/config.xml in text editor
      • Replace <includeRegex>on</includeRegex> by <includeRegex>your_regex</includeRegex> and save
      • Click hyperlink "Manage Jenkins" (URL /manage)
      • Click hyperlink "Reload Configuration from Disk" and button "OK" to confirm

        Attachments

          Issue Links

            Activity

            mwebber Matthew Webber added a comment -

            This bug has been reported in JENKINS-19082, and it looks like it has now been fixed. The fix should be in release 1.527.

            bgolding Ben Golding added a comment -

            JENKINS-19082 is still open, while 1.527 is already released.
            In fact I can confirm 1.527 does not fix it yet.

            I will wait for JENKINS-19082 to be closed.


              People

              • Assignee:
                Unassigned
                Reporter:
                bgolding Ben Golding
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: