Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19157

TestNG Results page for a specific test package displays some kind of source code

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: testng-plugin
    • Labels:
      None
    • Environment:
      RHEL 5.7 64 bit + JBoss 5.1.0 GA + Oracle JDK 1.6.0_24 64bit
    • Similar Issues:

      Description

      • Open the TestNG result for a specific test package
      • The page shows some Javascript code (See the screenshot attached)

      makeStaplerProxy('/jenkins/$stapler/bound/c0238010-3053-4b70-9280-6055bac80a06','80bf95ad-b8a8-403f-9b36-4fc2597014ac',['getAllSortedTestMethodsByStartTime','getFirstXSortedTestMethodsByStartTime']) foo.getAllSortedTestMethodsByStartTime(function(t)

      { document.getElementById('sortedMethods').innerHTML = t.responseObject(); }

      ) document.getElementById("showAllLink").style.display = "none"; }

        Attachments

          Activity

          zhh Hua Zhang added a comment -

          I also have exactly the same problem.
          Jenkins 1.625, testng plugin 0.33

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Nalin Makar
          Path:
          README
          src/main/resources/hudson/plugins/testng/results/PackageResult/reportDetail.groovy
          http://jenkins-ci.org/commit/testng-plugin-plugin/4767eb1660876a2d8498429e2e8220c3df87ff23
          Log:
          Fixed JENKINS-19157 - Make st:bind work when Jenkins has jQuery plugin installed

          See JENKINS-18867 and JENKINS-18875 for more context

          Testing: unit tests continue to pass. unable to reproduce this locally

          nullin Nalin Makar added a comment -

          Thanks for reporting the issue. The fix will be available in v1.5 in few days.


            People

            • Assignee:
              nullin Nalin Makar
              Reporter:
              ilynaf ily naf
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: