Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19198

HTML Publisher plugin for Hudson

    Details

    • Similar Issues:

      Description

      Using the OpenCover.Console.exe (Code coverage tool for .net apps Hudson) plugin to run tests and ReportGenerator.exe (1.6.1.0) to generate html reports for code coverage.
      Configured HTML Publisher plugin to display html reports for code coverage.
      HTML Publisher plugin displays reports but "Generated on" label displays date that is not uptodate.

      "Generated on" label in the Summary section displays old date as shown in the attached picture. After running the Hudson build date and time is not updated.

      I attached the screen shot showing HTML Publisher plugin configuration in Hudson.

      How can I make the date on "Generated On" label in the Summary section to reflect the time and date that matches the output of the html pages?

      Thank you,
      Marat

        Attachments

          Activity

          Hide
          mcrooney mcrooney added a comment -

          Hey there marat, thanks for using this plugin. The "Generated on" and fields you mention are coming from your OpenCover tool, not HTML Publisher. Your screenshot of the configuration cuts off the directory to archive, so maybe you can send that along, but it looks like it is either pointing at an old directory, or OpenCover is not generating new reports. I think you'll want to make sure OpenCover is generating new reports and that HTML Publisher is configured to point at the correct directory.

          Show
          mcrooney mcrooney added a comment - Hey there marat, thanks for using this plugin. The "Generated on" and fields you mention are coming from your OpenCover tool, not HTML Publisher. Your screenshot of the configuration cuts off the directory to archive, so maybe you can send that along, but it looks like it is either pointing at an old directory, or OpenCover is not generating new reports. I think you'll want to make sure OpenCover is generating new reports and that HTML Publisher is configured to point at the correct directory.
          Hide
          marat marat musaev added a comment -

          Thank you for response.
          Here is the full path to the directory: C:\Users\mmusaev\.hudson\jobs\Central_GUI\Code_Coverage

          And here is the windows batch command that Hudson runs:

          C:\OpenCover\OpenCover.Console.exe -target:"C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\MSTest.exe" -targetargs:/testcontainer:%WORKSPACE%\Central_GUI\Test.Entities\bin\Debug\Test.Wsi.Entities.dll /testcontainer:%WORKSPACE%\Central_GUI\Test.Util\bin\Debug\Test.Wsi.Util.dll
          /testcontainer:%WORKSPACE%\Central_GUI\Test.Main\bin\Debug\Test.Wsi.Main.dll
          /testcontainer:%WORKSPACE%\Central_GUI\Test.Common\bin\Debug\Test.Wsi.Common.dll
          C:\ReportGenerator_1.6.1.0\bin\ReportGenerator.exe %WORKSPACE%\results.xml ..\Code_Coverage HtmlSummary
          C:\ReportGenerator_1.6.1.0\bin\ReportGenerator.exe %WORKSPACE%\results.xml ..\Code_Coverage Html

          Here is the url in the browser:
          http://127.0.0.1:8080/job/Central_GUI/Code_Coverage/

          Thank you,
          Marat

          Show
          marat marat musaev added a comment - Thank you for response. Here is the full path to the directory: C:\Users\mmusaev\.hudson\jobs\Central_GUI\Code_Coverage And here is the windows batch command that Hudson runs: C:\OpenCover\OpenCover.Console.exe -target:"C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\MSTest.exe" -targetargs:/testcontainer:%WORKSPACE%\Central_GUI\Test.Entities\bin\Debug\Test.Wsi.Entities.dll /testcontainer:%WORKSPACE%\Central_GUI\Test.Util\bin\Debug\Test.Wsi.Util.dll /testcontainer:%WORKSPACE%\Central_GUI\Test.Main\bin\Debug\Test.Wsi.Main.dll /testcontainer:%WORKSPACE%\Central_GUI\Test.Common\bin\Debug\Test.Wsi.Common.dll C:\ReportGenerator_1.6.1.0\bin\ReportGenerator.exe %WORKSPACE%\results.xml ..\Code_Coverage HtmlSummary C:\ReportGenerator_1.6.1.0\bin\ReportGenerator.exe %WORKSPACE%\results.xml ..\Code_Coverage Html Here is the url in the browser: http://127.0.0.1:8080/job/Central_GUI/Code_Coverage/ Thank you, Marat
          Hide
          mcrooney mcrooney added a comment -

          Thanks Marat. I don't know if the spaces could be causing issues like "..\Code_Coverage Html" or if those are two separate arguments.

          Either way, this doesn't look at HTML Publisher bug but simply a case of OpenCover not updating the reports in the directory you've pointed HTML Publisher to. For example, if you investigate C:\Users\mmusaev\.hudson\jobs\Central_GUI\Code_Coverage manually I expect you'll find the same, older "Generated" dates you see when reviewing the report through Jenkins, meaning HTML Publisher is arching exactly what you are telling it to archive.

          Certainly let me know if I'm wrong though!

          Show
          mcrooney mcrooney added a comment - Thanks Marat. I don't know if the spaces could be causing issues like "..\Code_Coverage Html" or if those are two separate arguments. Either way, this doesn't look at HTML Publisher bug but simply a case of OpenCover not updating the reports in the directory you've pointed HTML Publisher to. For example, if you investigate C:\Users\mmusaev\.hudson\jobs\Central_GUI\Code_Coverage manually I expect you'll find the same, older "Generated" dates you see when reviewing the report through Jenkins, meaning HTML Publisher is arching exactly what you are telling it to archive. Certainly let me know if I'm wrong though!

            People

            • Assignee:
              mcrooney mcrooney
              Reporter:
              marat marat musaev
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: