Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19281

HTML Publisher Plugin get 404 error after upgrade to Jenkins ver. 1.528

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      404 error after upgrade jenkins to 1.528 when open report
      Works correct after downgrade to 1.527
      HTML publisher plugin ver is 1.2

        Attachments

          Issue Links

            Activity

            Hide
            acoulton Andrew Coulton added a comment -

            I can confirm this issue with Jenkins 1.528 and HTML Publisher 1.2. Files are correctly generated in

            {job}

            /builds/

            {#}

            /htmlreports/

            {report name}

            on disk but the server gives a 404 when clicking through to the report from either the job or the overall project page - the URL appears to be correct.

            Show
            acoulton Andrew Coulton added a comment - I can confirm this issue with Jenkins 1.528 and HTML Publisher 1.2. Files are correctly generated in {job} /builds/ {#} /htmlreports/ {report name} on disk but the server gives a 404 when clicking through to the report from either the job or the overall project page - the URL appears to be correct.
            Hide
            sue_c Sue C added a comment -

            Another confirmation with Jenkins 1.528 and HTML Publisher 1.2. Downgrade to 1.527 fixes for me too.

            Show
            sue_c Sue C added a comment - Another confirmation with Jenkins 1.528 and HTML Publisher 1.2. Downgrade to 1.527 fixes for me too.
            Hide
            schlauch Tobias Schlauch added a comment -

            I can confirm this problem with Jenkins 1.528 and HTML Publisher 1.2 (and earlier) as well.

            Show
            schlauch Tobias Schlauch added a comment - I can confirm this problem with Jenkins 1.528 and HTML Publisher 1.2 (and earlier) as well.
            Hide
            pt Peter Nijssen added a comment -

            I can confirm the issue as well

            Show
            pt Peter Nijssen added a comment - I can confirm the issue as well
            Hide
            mcrooney mcrooney added a comment -

            I've added "core" as a component for this, as since HTML Publisher hasn't changed, this is likely a core Jenkins bug. The best option is to use 1.527 I imagine.

            Show
            mcrooney mcrooney added a comment - I've added "core" as a component for this, as since HTML Publisher hasn't changed, this is likely a core Jenkins bug. The best option is to use 1.527 I imagine.
            Hide
            zfil Philippe Jandot added a comment -

            This bug is related to the use of stapler 1.217.

            If I use stapler 1.214 with jenkins 1.528 it works again so I guess it is a bug in stapler.

            Show
            zfil Philippe Jandot added a comment - This bug is related to the use of stapler 1.217. If I use stapler 1.214 with jenkins 1.528 it works again so I guess it is a bug in stapler.
            Hide
            torq Jari Siikarla added a comment - - edited

            I'm having the same 404 problem with HTML Publisher Plugin after updating from pre1.528 to 1.529.

            Files get copied to the same loation as before, but the link on job-page is not working.

            The people page works.

            HTML Publisher Plugin ver.1.20
            Running Jenkins on Windows 7 64bit
            Didn't find Stapler version

            Show
            torq Jari Siikarla added a comment - - edited I'm having the same 404 problem with HTML Publisher Plugin after updating from pre1.528 to 1.529. Files get copied to the same loation as before, but the link on job-page is not working. The people page works. HTML Publisher Plugin ver.1.20 Running Jenkins on Windows 7 64bit Didn't find Stapler version
            Hide
            jglick Jesse Glick added a comment -

            @torq the fix is in 1.530.

            Show
            jglick Jesse Glick added a comment - @torq the fix is in 1.530.
            Hide
            calysto_ramesh ramesh kumar added a comment -

            I can confirm this problem with Jenkins 1.542 and HTML Publisher 1.2 as well.

            Show
            calysto_ramesh ramesh kumar added a comment - I can confirm this problem with Jenkins 1.542 and HTML Publisher 1.2 as well.
            Hide
            samit Samit Dutta added a comment -

            i m using Jenkins 1.642 and HTMLPublisher plugin 1.4 .on clicking the hyperlink on the jenkins console it is unable to load the html file.Html file is already available at the specified location

            Show
            samit Samit Dutta added a comment - i m using Jenkins 1.642 and HTMLPublisher plugin 1.4 .on clicking the hyperlink on the jenkins console it is unable to load the html file.Html file is already available at the specified location
            Hide
            vidaljessi Jessica Vidal added a comment -

            Hi I am using Jenkins ver. 2.11 and Html Publisher 1.10 and it is not working. Could you please confirm that only works with Jenkins 1.527?

            Show
            vidaljessi Jessica Vidal added a comment - Hi I am using Jenkins ver. 2.11 and Html Publisher 1.10 and it is not working. Could you please confirm that only works with Jenkins 1.527?
            Hide
            laxmi_nallabothula Laxmi Nallabothula added a comment -

            I have the same problem with one of the jobs :

             
            13:48:03 [htmlpublisher] Archiving HTML reports...13:48:03 [htmlpublisher] Archiving at PROJECT level /home/build/jenkins/workspace/mq-master/build/reports/tests to /var/lib/jenkins/jobs/mq-master/htmlreports/Test_Summary_Report
             

            But can't see the report 

             

            Show
            laxmi_nallabothula Laxmi Nallabothula added a comment - I have the same problem with one of the jobs :   13:48:03 [htmlpublisher] Archiving HTML reports... 13:48:03 [htmlpublisher] Archiving at PROJECT level /home/build/jenkins/workspace/mq-master/build/reports/tests to /var/lib/jenkins/jobs/mq-master/htmlreports/Test_Summary_Report   But can't see the report   
            Hide
            r2b2_nz Richard Bywater added a comment -

            Hi - this issue has been around and not touched for a year or more. In an effort to try and focus on issues which are still present, I am resolving these issues for now.

            If you feel that the issue is still present, please feel free to re-open / comment. I'll be closing off any issues that haven't had any re-opening or comments by the end of the month.

            Thanks for reporting these issues - hopefully you are still using HTML Publisher and its working for you but, if not, let me know so that I can focus on issues that are causing you problems today

            Show
            r2b2_nz Richard Bywater added a comment - Hi - this issue has been around and not touched for a year or more. In an effort to try and focus on issues which are still present, I am resolving these issues for now. If you feel that the issue is still present, please feel free to re-open / comment. I'll be closing off any issues that haven't had any re-opening or comments by the end of the month. Thanks for reporting these issues - hopefully you are still using HTML Publisher and its working for you but, if not, let me know so that I can focus on issues that are causing you problems today

              People

              • Assignee:
                r2b2_nz Richard Bywater
                Reporter:
                svs57 Sergey Smirnov
              • Votes:
                11 Vote for this issue
                Watchers:
                22 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: