Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19366

Configure tab freezes for projects

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      Tomcat6
      Browsers: Everything from Safari to Firefox
      OS: Linux Ubuntu 12.04, OSX and Windows 2008
    • Similar Issues:

      Description

      When clicking on the configuration tab of a project, the "LOADING" message stays there forever. The values shown on the configuration are wrong and it is impossible to edit the configuration of a project.

      It is still possible to edit the configuration of a project manually by hacking up the xml file, but it is a very tedious process.

        Attachments

          Issue Links

            Activity

            tboven Tim Boven added a comment -

            I'm having the same issue.

            During the testing I've done, I noticed that:

            • the general configure-screen (of jenkins itself) works but the configure of the jobs is blocked by this issue
            • the save-buttom becomes available (as soon as the screen isn't loading anymore but the overlay is still in front of the top of the page) but when I click it, I get "net::ERR_CONTENT_DECODING_FAILED"
            gcummings Geoff Cummings added a comment -

            sounds like it may be the same issue as JENKINS-19248

            What version of Jenkins are you using?

            patrickhancke Patrick Hancke added a comment -

            Same here with Jenkins 1.529 on RHEL.

            carlosduclos Carlos Duclos added a comment -

            I upgraded to 1.530 and still the same. I installed a new Jenkins instance on a test machine and as long as I did not install any plug ins this issue was not present. The moment I installed plugins this issue started appearing.
            At first I only had the plugins that come by default and the "Github pull request" plugin. With that configuration this issue did not appear.
            This is the list of plugins I have installed (all of them via the "Manage Plugins" from "Manage Jenkins":

            Ant Plugin 1.2
            Build Failure Analyzer 1.5.0
            Build Pipeline Plugin 1.4
            build-metrics 1.0
            conditional-buildstep 1.3.1
            Credentials Plugin 1.7.6
            Dashboard View 2.9.1
            database 1.3
            database-mysql 1.0
            database-postgresql 1.0
            External Monitor Job Type Plugin 1.2
            Fingerprint Plugin 1.2
            GitHub API Plugin 1.44
            GitHub plugin 1.8
            GitHub Pull Request Builder 1.9
            HTML Publisher plugin 1.2
            Hudson global-build-stats plugin 1.3
            Javadoc Plugin 1.1
            Jenkins Audit to Database Plugin 0.5
            Jenkins Clone Workspace SCM Plug-in 0.6
            Jenkins CVS Plug-in 2.9
            Jenkins Doxygen Plug-in 0.14
            Jenkins Email Extension Plugin 2.32
            Jenkins GIT client plugin 1.1.2
            Jenkins GIT plugin 1.5.0
            Jenkins jQuery plugin 1.7.2-1
            Jenkins Mailer Plugin 1.5
            Jenkins Multiple SCMs plugin 0.2
            Jenkins Parameterized Trigger plugin 2.20
            Jenkins SSH Slaves plugin 1.2
            Jenkins Subversion Plug-in 1.50
            Jenkins Translation Assistance plugin 1.10
            LDAP Plugin 1.6
            Maven Integration plugin 1.530
            PAM Authentication plugin 1.1
            Publish Over SSH 1.10
            Run Condition Plugin 0.10
            SSH Credentials Plugin 1.4
            Test stability history 1.0
            Token Macro Plugin 1.8.1

            carlosduclos Carlos Duclos added a comment -

            I went through all the plugins, enabling and disabling them. After several tests I can say with some certainty that the Publish Over SSH plugin is causing the problem. As soon as I enable it, this problem comes back.

            carlosduclos Carlos Duclos added a comment -

            Given that this issue has happened with two different and unrelated plugins, it might be that the root cause is somewhere in the core.
            My bet would be that the configuration freeze for projects is due to a plugin not providing what is expected and the loader not detecting that.

            danielbeck Daniel Beck added a comment -

            Given the versions mentioned in the comments, this is likely a duplicate of JENKINS-19457 which was fixed in 1.531.


              People

              • Assignee:
                Unassigned
                Reporter:
                carlosduclos Carlos Duclos
              • Votes:
                2 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: