Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Not A Defect
    • Labels:
      None
    • Environment:
      O/S: Windows 7 SP1;
      Java: JDK 1.6.0_20;
      Container: WebLogic Server 10.3.0.0
      Jenkins 1.509.2
      Analysis-Core 1.53
      Findbugs 4.50
    • Similar Issues:

      Description

      I am unable to install findbugs and checkstyle plug-ins. I get the following errors after manually uploading the findbugs and checkstyle plug-ins and restarting WebLogic server.

      Findbugs:

      28-Aug-2013 8:37:45 AM org.apache.commons.digester3.Digester getParser
      SEVERE: Digester.getParser:
      java.lang.UnsupportedOperationException: This parser does not support specification "null" version "null"
      at javax.xml.parsers.SAXParserFactory.setXIncludeAware(SAXParserFactory.java:448)
      at org.apache.commons.digester3.Digester.getFactory(Digester.java:439)
      at org.apache.commons.digester3.Digester.getParser(Digester.java:652)
      at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)

      at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
      at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
      at hudson.plugins.findbugs.FindBugsMessages.parse(FindBugsMessages.java:108)
      at hudson.plugins.findbugs.FindBugsMessages.loadMessages(FindBugsMessages.java:71)
      at hudson.plugins.findbugs.FindBugsMessages.initialize(FindBugsMessages.java:53)
      at hudson.plugins.findbugs.FindBugsPlugin.start(FindBugsPlugin.java:28)
      at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:379)
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:368)
      at hudson.PluginManager$2$1$1.run(PluginManager.java:333)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:888)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)
      28-Aug-2013 8:37:45 AM jenkins.InitReactorRunner$1 onTaskFailed
      SEVERE: Failed Loading plugin findbugs
      hudson.util.IOException2: Failed to initialize
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:371)
      at hudson.PluginManager$2$1$1.run(PluginManager.java:333)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:888)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.NullPointerException
      at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)

      at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
      at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
      at hudson.plugins.findbugs.FindBugsMessages.parse(FindBugsMessages.java:108)
      at hudson.plugins.findbugs.FindBugsMessages.loadMessages(FindBugsMessages.java:71)
      at hudson.plugins.findbugs.FindBugsMessages.initialize(FindBugsMessages.java:53)
      at hudson.plugins.findbugs.FindBugsPlugin.start(FindBugsPlugin.java:28)
      at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:379)
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:368)
      ... 9 more

      Checkstyle:

      28-Aug-2013 10:50:53 AM org.apache.commons.digester3.Digester getParser
      SEVERE: Digester.getParser:
      java.lang.UnsupportedOperationException: This parser does not support specification "null" version "null"
      at javax.xml.parsers.SAXParserFactory.setXIncludeAware(SAXParserFactory.java:448)
      at org.apache.commons.digester3.Digester.getFactory(Digester.java:439)
      at org.apache.commons.digester3.Digester.getParser(Digester.java:652)
      at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)
      at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
      at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
      at hudson.plugins.checkstyle.rules.CheckStyleRules.initialize(CheckStyleRules.java:60)
      at hudson.plugins.checkstyle.CheckStylePlugin.start(CheckStylePlugin.java:23)
      at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:379)
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:368)
      at hudson.PluginManager$2$1$1.run(PluginManager.java:333)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:888)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)
      28-Aug-2013 10:50:53 AM jenkins.InitReactorRunner$1 onTaskFailed
      SEVERE: Failed Loading plugin checkstyle
      hudson.util.IOException2: Failed to initialize
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:371)
      at hudson.PluginManager$2$1$1.run(PluginManager.java:333)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:888)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.NullPointerException
      at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)
      at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
      at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
      at hudson.plugins.checkstyle.rules.CheckStyleRules.initialize(CheckStyleRules.java:60)
      at hudson.plugins.checkstyle.CheckStylePlugin.start(CheckStylePlugin.java:23)
      at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:379)
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:368)
      ... 9 more

      I have tried re-installing latest version of analysis-core and findbugs, but still getting the same results.

      Any help would be appreciated.

        Attachments

          Activity

          pavelsaab Pavel Saab created issue -
          drulli Ulli Hafner added a comment -

          Can you please try without weblogic? Maybe there is a conflicting library in weblogics classpath.

          pavelsaab Pavel Saab made changes -
          Field Original Value New Value
          Description I am unable to install findbugs plug-in. I get the following errors after manually uploading the findbugs plug-in and restarting WebLogic server.

          28-Aug-2013 8:37:45 AM org.apache.commons.digester3.Digester getParser
          SEVERE: Digester.getParser:
          java.lang.UnsupportedOperationException: This parser does not support specification "null" version "null"
                  at javax.xml.parsers.SAXParserFactory.setXIncludeAware(SAXParserFactory.java:448)
                  at org.apache.commons.digester3.Digester.getFactory(Digester.java:439)
                  at org.apache.commons.digester3.Digester.getParser(Digester.java:652)
                  at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)

                  at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
                  at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
                  at hudson.plugins.findbugs.FindBugsMessages.parse(FindBugsMessages.java:108)
                  at hudson.plugins.findbugs.FindBugsMessages.loadMessages(FindBugsMessages.java:71)
                  at hudson.plugins.findbugs.FindBugsMessages.initialize(FindBugsMessages.java:53)
                  at hudson.plugins.findbugs.FindBugsPlugin.start(FindBugsPlugin.java:28)
                  at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:379)
                  at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:368)
                  at hudson.PluginManager$2$1$1.run(PluginManager.java:333)
                  at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
                  at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
                  at jenkins.model.Jenkins$7.runTask(Jenkins.java:888)
                  at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
                  at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
                  at java.lang.Thread.run(Thread.java:619)
          28-Aug-2013 8:37:45 AM jenkins.InitReactorRunner$1 onTaskFailed
          SEVERE: Failed Loading plugin findbugs
          hudson.util.IOException2: Failed to initialize
                  at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:371)
                  at hudson.PluginManager$2$1$1.run(PluginManager.java:333)
                  at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
                  at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
                  at jenkins.model.Jenkins$7.runTask(Jenkins.java:888)
                  at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
                  at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
                  at java.lang.Thread.run(Thread.java:619)
          Caused by: java.lang.NullPointerException
                  at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)

                  at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
                  at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
                  at hudson.plugins.findbugs.FindBugsMessages.parse(FindBugsMessages.java:108)
                  at hudson.plugins.findbugs.FindBugsMessages.loadMessages(FindBugsMessages.java:71)
                  at hudson.plugins.findbugs.FindBugsMessages.initialize(FindBugsMessages.java:53)
                  at hudson.plugins.findbugs.FindBugsPlugin.start(FindBugsPlugin.java:28)
                  at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:379)
                  at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:368)
                  ... 9 more

          I have tried re-installing latest version of analysis-core and findbugs, but still getting the same results.

          Any help would be appreciated.
          I am unable to install findbugs and checkstyle plug-ins. I get the following errors after manually uploading the findbugs and checkstyle plug-ins and restarting WebLogic server.

          Findbugs:

          28-Aug-2013 8:37:45 AM org.apache.commons.digester3.Digester getParser
          SEVERE: Digester.getParser:
          java.lang.UnsupportedOperationException: This parser does not support specification "null" version "null"
                  at javax.xml.parsers.SAXParserFactory.setXIncludeAware(SAXParserFactory.java:448)
                  at org.apache.commons.digester3.Digester.getFactory(Digester.java:439)
                  at org.apache.commons.digester3.Digester.getParser(Digester.java:652)
                  at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)

                  at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
                  at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
                  at hudson.plugins.findbugs.FindBugsMessages.parse(FindBugsMessages.java:108)
                  at hudson.plugins.findbugs.FindBugsMessages.loadMessages(FindBugsMessages.java:71)
                  at hudson.plugins.findbugs.FindBugsMessages.initialize(FindBugsMessages.java:53)
                  at hudson.plugins.findbugs.FindBugsPlugin.start(FindBugsPlugin.java:28)
                  at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:379)
                  at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:368)
                  at hudson.PluginManager$2$1$1.run(PluginManager.java:333)
                  at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
                  at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
                  at jenkins.model.Jenkins$7.runTask(Jenkins.java:888)
                  at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
                  at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
                  at java.lang.Thread.run(Thread.java:619)
          28-Aug-2013 8:37:45 AM jenkins.InitReactorRunner$1 onTaskFailed
          SEVERE: Failed Loading plugin findbugs
          hudson.util.IOException2: Failed to initialize
                  at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:371)
                  at hudson.PluginManager$2$1$1.run(PluginManager.java:333)
                  at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
                  at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
                  at jenkins.model.Jenkins$7.runTask(Jenkins.java:888)
                  at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
                  at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
                  at java.lang.Thread.run(Thread.java:619)
          Caused by: java.lang.NullPointerException
                  at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)

                  at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
                  at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
                  at hudson.plugins.findbugs.FindBugsMessages.parse(FindBugsMessages.java:108)
                  at hudson.plugins.findbugs.FindBugsMessages.loadMessages(FindBugsMessages.java:71)
                  at hudson.plugins.findbugs.FindBugsMessages.initialize(FindBugsMessages.java:53)
                  at hudson.plugins.findbugs.FindBugsPlugin.start(FindBugsPlugin.java:28)
                  at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:379)
                  at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:368)
                  ... 9 more

          Checkstyle:

          28-Aug-2013 10:50:53 AM org.apache.commons.digester3.Digester getParser
          SEVERE: Digester.getParser:
          java.lang.UnsupportedOperationException: This parser does not support specification "null" version "null"
                  at javax.xml.parsers.SAXParserFactory.setXIncludeAware(SAXParserFactory.java:448)
                  at org.apache.commons.digester3.Digester.getFactory(Digester.java:439)
                  at org.apache.commons.digester3.Digester.getParser(Digester.java:652)
                  at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)
                  at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
                  at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
                  at hudson.plugins.checkstyle.rules.CheckStyleRules.initialize(CheckStyleRules.java:60)
                  at hudson.plugins.checkstyle.CheckStylePlugin.start(CheckStylePlugin.java:23)
                  at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:379)
                  at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:368)
                  at hudson.PluginManager$2$1$1.run(PluginManager.java:333)
                  at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
                  at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
                  at jenkins.model.Jenkins$7.runTask(Jenkins.java:888)
                  at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
                  at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
                  at java.lang.Thread.run(Thread.java:619)
          28-Aug-2013 10:50:53 AM jenkins.InitReactorRunner$1 onTaskFailed
          SEVERE: Failed Loading plugin checkstyle
          hudson.util.IOException2: Failed to initialize
                  at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:371)
                  at hudson.PluginManager$2$1$1.run(PluginManager.java:333)
                  at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
                  at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
                  at jenkins.model.Jenkins$7.runTask(Jenkins.java:888)
                  at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
                  at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
                  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
                  at java.lang.Thread.run(Thread.java:619)
          Caused by: java.lang.NullPointerException
                  at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)
                  at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
                  at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
                  at hudson.plugins.checkstyle.rules.CheckStyleRules.initialize(CheckStyleRules.java:60)
                  at hudson.plugins.checkstyle.CheckStylePlugin.start(CheckStylePlugin.java:23)
                  at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:379)
                  at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:368)
                  ... 9 more


          I have tried re-installing latest version of analysis-core and findbugs, but still getting the same results.

          Any help would be appreciated.
          Component/s checkstyle [ 15512 ]
          pavelsaab Pavel Saab added a comment -

          I'll try it without WebLogic.

          pavelsaab Pavel Saab added a comment -

          I ran Jenkins by itself and was able to successfully load and test both plug-ins. However, I still need to be able to run Jenkins on a WebLogic Server. Any idea what library might be causing this issue? Could it be the XML parser?

          It looks like my Weblogic is using the following:

          org.xml.sax.driver = weblogic.xml.jaxp.RegistryXMLReader
          org.xml.sax.parser = weblogic.xml.jaxp.RegistryParser

          drulli Ulli Hafner added a comment -

          Yes, seems like there is an incompatible XML parser in the classpath. However, I'm setting the parser to org.apache.xerces.parsers.SAXParser. Maybe in Weblogic there is an old version of Xerces installed in the boot classloader path...

          drulli Ulli Hafner added a comment -

          Needs to be fixed in websphere class path.

          drulli Ulli Hafner made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Not A Defect [ 7 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 150843 ] JNJira + In-Review [ 193700 ]

            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              pavelsaab Pavel Saab
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: