Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19403

Unable to Open Report Created by HTML Publisher Plugin

    Details

    • Similar Issues:

      Description

      Using the OpenCover.Console.exe (Code coverage tool for .net apps) plugin to run tests and ReportGenerator.exe (1.9.0.0) to generate html reports for code coverage.
      Configured HTML Publisher plugin (1.2) to display html reports for code coverage.
      HTML Publisher plugin creates the link on the dashboard but after clicking the link unable to see the report and it's shows the below error:

      Status Code: 404

      Exception:
      Stacktrace:
      (none)

      I have attached the screen shot showing HTML Publisher plugin configuration and other related details.

        Attachments

        1. Code Coverage Link Generated.JPG
          Code Coverage Link Generated.JPG
          38 kB
        2. consoleoutput.PNG
          consoleoutput.PNG
          24 kB
        3. filesystem1.PNG
          filesystem1.PNG
          14 kB
        4. filesystem2.PNG
          filesystem2.PNG
          13 kB
        5. Internally Reports Generated.JPG
          Internally Reports Generated.JPG
          84 kB
        6. Job Config.JPG
          Job Config.JPG
          104 kB
        7. Job Sueess_Console Output.JPG
          Job Sueess_Console Output.JPG
          146 kB
        8. localhost404.PNG
          localhost404.PNG
          16 kB
        9. screenshot-1.jpg
          screenshot-1.jpg
          113 kB
        10. screenshot-2.jpg
          screenshot-2.jpg
          72 kB
        11. Unable to See the HTML Report - Error 404.JPG
          Unable to See the HTML Report - Error 404.JPG
          24 kB

          Activity

          Hide
          nishank_78 Nishant Kansal added a comment -

          This issue exists even now. htmlpublisher plugin is not able to generate reports with below error. Jenkins version in use is "Jenkins ver. 1.651.3"

          *HTTP ERROR 404

          Problem accessing /job/SoapUI/Soapui/index.xhtml. Reason:

          Not Found*

          Show
          nishank_78 Nishant Kansal added a comment - This issue exists even now. htmlpublisher plugin is not able to generate reports with below error. Jenkins version in use is "Jenkins ver. 1.651.3" *HTTP ERROR 404 Problem accessing /job/SoapUI/Soapui/index.xhtml. Reason: Not Found*
          Hide
          r2b2_nz Richard Bywater added a comment -

          Hi - this issue has been around and not touched for a year or more. In an effort to try and focus on issues which are still present, I am resolving these issues for now.

          If you feel that the issue is still present, please feel free to re-open / comment. I'll be closing off any issues that haven't had any re-opening or comments by the end of the month.

          Thanks for reporting these issues - hopefully you are still using HTML Publisher and its working for you but, if not, let me know so that I can focus on issues that are causing you problems today

          Show
          r2b2_nz Richard Bywater added a comment - Hi - this issue has been around and not touched for a year or more. In an effort to try and focus on issues which are still present, I am resolving these issues for now. If you feel that the issue is still present, please feel free to re-open / comment. I'll be closing off any issues that haven't had any re-opening or comments by the end of the month. Thanks for reporting these issues - hopefully you are still using HTML Publisher and its working for you but, if not, let me know so that I can focus on issues that are causing you problems today
          Hide
          tenaciousrm Randell Maree added a comment -

          Hi, I'm also still experiencing the same issue.

          Show
          tenaciousrm Randell Maree added a comment - Hi, I'm also still experiencing the same issue.
          Hide
          r2b2_nz Richard Bywater added a comment -

          Hi Randell Maree - are you able to please raise a new issue and provide any relevant screenshots/job configuration/pipeline code/etc. to show exactly what issue you are seeing? Thanks.

          Show
          r2b2_nz Richard Bywater added a comment - Hi  Randell Maree - are you able to please raise a new issue and provide any relevant screenshots/job configuration/pipeline code/etc. to show exactly what issue you are seeing? Thanks.
          Hide
          luckyluky Lucky Luky added a comment - - edited

          Hi,

          I'm experiencing the same problem. I have attached two screenshots:

            1.'localhost404'

            2. 'consoleoutput'

            3. 'filesystem1'

            4. 'filesystem2'

           

          What did i do wrong?

          Please help.

          Show
          luckyluky Lucky Luky added a comment - - edited Hi, I'm experiencing the same problem. I have attached two screenshots:   1.'localhost404'   2. 'consoleoutput'   3. 'filesystem1'   4. 'filesystem2'   What did i do wrong? Please help.

            People

            • Assignee:
              r2b2_nz Richard Bywater
              Reporter:
              mngcorp Mitesh Gandhi
            • Votes:
              2 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated: