Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19409

Support case-insensitive mode for user IDs

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      We use this plugin with Active Directory users authorisation and via AD user can be authorised with lowercase and CamelCase names. But "role-strategy" plugin uses exact user name and we have to register two user names for each user - lowercase and CamelCase.

        Attachments

          Issue Links

            Activity

            msavich Alex created issue -
            oleg_nenashev Oleg Nenashev added a comment -

            Issue is caused by active-directory plugin

            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Link This issue is related to JENKINS-12607 [ JENKINS-12607 ]
            oleg_nenashev Oleg Nenashev added a comment - - edited

            https://issues.jenkins-ci.org/browse/JENKINS-19320 can resolve this issue for role-strategy plugin.
            I'm going to implement such feature at the October

            oleg_nenashev Oleg Nenashev made changes -
            Link This issue is related to JENKINS-19320 [ JENKINS-19320 ]
            oleg_nenashev Oleg Nenashev made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Pull request: https://github.com/jenkinsci/role-strategy-plugin/pull/5
            You can find test hpi in attachments

            oleg_nenashev Oleg Nenashev added a comment -

            Attached hpi with a fix

            oleg_nenashev Oleg Nenashev made changes -
            Attachment role-strategy.hpi [ 24292 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Alexey, please test the plugin against ActiveDirectory. It works well for me (LDAP and LocalDatabase)

            oleg_nenashev Oleg Nenashev made changes -
            Status In Progress [ 3 ] Resolved [ 5 ]
            Assignee Oleg Nenashev [ oleg_nenashev ] Alex [ msavich ]
            Resolution Fixed [ 1 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Global configuration example

            oleg_nenashev Oleg Nenashev made changes -
            Attachment configure_cases.png [ 24293 ]
            waltern Walter Nagler added a comment -

            Works for me, too.
            In combination with Active Directory plugin

            batmat Baptiste Mathus added a comment -

            +1. IMO this would be better to not mark this issue as fixed for communication, since the code has actually not reached master (still in the PR).

            oleg_nenashev Oleg Nenashev made changes -
            Summary User names should not be case sensitive. Support case-insensitive mode for user IDs
            Issue Type Bug [ 1 ] Improvement [ 4 ]
            oleg_nenashev Oleg Nenashev made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            Assignee Alex [ msavich ] Oleg Nenashev [ oleg_nenashev ]
            oleg_nenashev Oleg Nenashev added a comment -

            Baptiste Mathus, I've reopened the issue.

            I'll consider the merge of the PR in the next release.

            batmat Baptiste Mathus added a comment - - edited

            Oleg Nenashev Great! Thanks!

            pixman20 pixman20 added a comment - - edited

            Has this been verified to work when using the "authenticated" special "user" when assigning roles.
            It may be that it works inherently, but I just want to verify prior to release.
            Also, will the update provide an option or will it automatically be case insensitive? (n/m, just saw the png)

            oleg_nenashev Oleg Nenashev added a comment -

            @pixman20
            Yes, it should work with the "authenticated" user group.
            If you want to perform an additional testing, I can provide the plugin's build with the patch. Such contribution will be appreciated.

            pixman20 pixman20 added a comment - - edited

            Oleg Nenashev, I'd be happy to contribute and test it out. Feel free to email me (address in profile) unless there's somewhere I can grab it from. Thanks!

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 150857 ] JNJira + In-Review [ 186152 ]
            bherfurth Ben Herfurth added a comment -

            What about the merge?

            bherfurth Ben Herfurth made changes -
            Priority Major [ 3 ] Critical [ 2 ]
            fsteff Flemming Steffensen added a comment -

            Believe I'm seeing this problem.

            Users will be granted different access, whether they are logging in as lower-case "username" or have any or all letters capitalized.

            If there's still something that needs to be tested prior to merge, please contact me - I'd be happy to test.

            oleg_nenashev Oleg Nenashev made changes -
            Labels gsoc-2019-project-idea
            oleg_nenashev Oleg Nenashev made changes -
            Assignee Oleg Nenashev [ oleg_nenashev ]
            oleg_nenashev Oleg Nenashev added a comment -
            oleg_nenashev Oleg Nenashev made changes -
            Labels gsoc-2019-project-idea gsoc-2019-project-idea user-experience
            oleg_nenashev Oleg Nenashev added a comment -

            I believe that a proper implementation nowadays would be an integration with User ID strategies from JENKINS-22247: https://javadoc.jenkins.io/jenkins/model/IdStrategy.html. Such extension point is available in recent versions

            oleg_nenashev Oleg Nenashev made changes -
            Link This issue relates to JENKINS-22247 [ JENKINS-22247 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                msavich Alex
              • Votes:
                13 Vote for this issue
                Watchers:
                16 Start watching this issue

                Dates

                • Created:
                  Updated: