Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: ssh-slaves-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.529
      OSX 10.8.4 (running as a VMWare Guest in VMWare Workstation 9.0.2 inside a Windows 7 Host)
      also Jenkins 1.645, OSX 10.9, 10.10 (not vm)
      also observed with Windows and Linux slaves.
    • Similar Issues:
    • Released As:
      ssh-slaves-1.31.1

      Description

      I configured an OSX slave to use an SSH connection. I have an identical setup for a Linux slave. The Linux slave never hangs, but the OSX one does randomly every couple of days.

      When the slave hangs, I see:

      This node is being launched. See log for more details
      

      When I click on more details I see an empty log (literally no characters) with a spinning wheel.

      I'd like to disconnect the channel and try again. Unfortunately, there is no "disconnect" button, seemingly because the hang occurs too early in the connection phase.

      The only way I found to fix this problem is restart Jenkins master. I believe this issue is high priority because:

      1. This hang occurs at least once a day (for over a week now).
      2. There is no known workaround.
      3. There is no way to recover except to restart the master node, which means that all running jobs have to be interrupted.

      If you can add extra logging, I can try collection more information for you. Where do we get started?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ifernandezcalvo Ivan Fernandez Calvo
                Reporter:
                cowwoc cowwoc
              • Votes:
                12 Vote for this issue
                Watchers:
                23 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: