Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19600

Subversion Plugin 1.51 consistently throws NoSuchMethodError

    Details

    • Similar Issues:

      Description

      After upgrading Subversion plugin to version 1.51, no SVN checkouts would work properly. Downgrading to 1.50 fixes the problem.

      Stack trace follows...

      FATAL: com.trilead.ssh2.Connection.connect(Lcom/trilead/ssh2/ServerHostKeyVerifier;III)Lcom/trilead/ssh2/ConnectionInfo;
      java.lang.NoSuchMethodError: com.trilead.ssh2.Connection.connect(Lcom/trilead/ssh2/ServerHostKeyVerifier;III)Lcom/trilead/ssh2/ConnectionInfo;
      	at org.tmatesoft.svn.core.internal.io.svn.ssh.SshHost.openConnection(SshHost.java:225)
      	at org.tmatesoft.svn.core.internal.io.svn.ssh.SshHost.openSession(SshHost.java:153)
      	at org.tmatesoft.svn.core.internal.io.svn.ssh.SshSessionPool.openSession(SshSessionPool.java:85)
      	at org.tmatesoft.svn.core.internal.io.svn.SVNSSHConnector.open(SVNSSHConnector.java:122)
      	at org.tmatesoft.svn.core.internal.io.svn.SVNConnection.open(SVNConnection.java:77)
      	at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.openConnection(SVNRepositoryImpl.java:1252)
      	at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.testConnection(SVNRepositoryImpl.java:95)
      	at hudson.scm.SubversionSCM$DescriptorImpl.checkRepositoryPath(SubversionSCM.java:2047)
      	at hudson.scm.SubversionSCM.repositoryLocationsNoLongerExist(SubversionSCM.java:2226)
      	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:832)
      	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:788)
      	at hudson.model.AbstractProject.checkout(AbstractProject.java:1408)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:657)
      	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:562)
      	at hudson.model.Run.execute(Run.java:1603)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:246)
      

        Attachments

          Activity

          tpreston Tim Preston created issue -
          bep Bernd bep added a comment -

          same for me

          mrcaffeine Kerstin Klein added a comment -

          same here. Downgrade to 1.50 fixes it.

          odemia Tim Fretz added a comment -

          Same here. Workaround is to downgrade.

          mwebber Matthew Webber added a comment -

          We also had the same problem.

          mwebber Matthew Webber made changes -
          Field Original Value New Value
          Priority Major [ 3 ] Blocker [ 1 ]
          mwebber Matthew Webber added a comment -

          I'm guessing that this is related to one of these two updates in this release:

          add trilead-ssh2 dependency
          Upgrade svnkit dependency to 1.7.10

          so assigning to Nicolas to take a look

          mwebber Matthew Webber made changes -
          Assignee Nicolas De Loof [ ndeloof ]
          mariusvw Marius van Witzenburg added a comment -

          We use svn+ssh, upgrading caused me to ran into this error. Downgrading to 1.50 caused the following:

          Caused by: svn: E210004: Number is larger than maximum

          Which is already reported here:
          https://issues.jenkins-ci.org/browse/JENKINS-18844
          in relation with
          https://issues.jenkins-ci.org/browse/JENKINS-18935

          ndeloof Nicolas De Loof added a comment -

          svnkit 1.7 require trilead-ssh2 build 217, but jenkins-core one (build214) is preferred by classloader.

          mdkf Michael Fowler added a comment -

          Still broken in 1.53

          urkon Uroš Malenšek added a comment -

          Also broken after 1.53 update

          chinboon Chin Boon Oh added a comment -

          Experiencing the same here, fails on 1.5.1 and 1.5.3.

          aaubert alexandre aubert added a comment -

          i don't know if this could help but i have the same problem, running jenkins on windows XP and with svn 1.7 installed on remote server.

          mhans Martin Hans added a comment -

          Upgrading to 1.536 fixed this for me. I had to update the slave's .jar file as well.

          chinboon Chin Boon Oh added a comment -

          Hi @Martin Hans, what version of 'Subversion Plugin' do you have that worked with Jenkins 1.536.

          mhans Martin Hans added a comment -

          Version 1.53.

          warandpeace Andrew Ferguson added a comment - - edited

          Looks like trilead-ssh2 was updated to build 217 in Jenkins core as of 1.536:

          JENKINS-18836 ( From the 1.536 Changelog http://jenkins-ci.org/changelog )

          Commit: https://github.com/jenkinsci/jenkins/commit/bb265c5e95b0fe39128720b903914236962db41b

          That's likely why this is now working for Martin

          I may not upgrade yet as I'm still hoping for a JENKINS-17614 fix before I risk making the problem worse, but if anyone else wants to try & report back feel free.

          tpreston Tim Preston added a comment -

          I can verify that Subversion Plugin 1.53 is working properly with Jenkins 1.537.

          pancake pancake added a comment -

          Does it reproduce on LTS? More specifically, does it reproduce on 1.509.2?

          bep Bernd bep added a comment -

          It happened to me on LTS 1.509.x, x<4, but I do no remember the exact x and plugin 1.51.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Nicolas De Loof
          Path:
          pom.xml
          http://jenkins-ci.org/commit/subversion-plugin/9aba1bd5049d38acfefd6f81d2cbc0ede5e2e0c8
          Log:
          [FIXED JENKINS-19600] prefer trilead-ssh from plugin vs core classloader

          scm_issue_link SCM/JIRA link daemon made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Christoph Kutzinski
          Path:
          pom.xml
          http://jenkins-ci.org/commit/subversion-plugin/b5cd30370ef40439c37b7350810d3469b9a17fc1
          Log:
          Merge pull request #53 from ndeloof/JENKINS-19600

          [FIXED JENKINS-19600] prefer trilead-ssh from plugin vs core classloader

          Compare: https://github.com/jenkinsci/subversion-plugin/compare/3e941d8dc920...b5cd30370ef4

          kto Kimmo Toro added a comment -

          Still getting this error with Jenkins 1.509.4 and Subversion plugin version 1.54

          mariusvw Marius van Witzenburg added a comment -

          Jenkins version 1.536 and Subversion plugin 1.53 works perfectly.

          Seems to be fixed to me.

          acolichia Aaron Colichia added a comment -

          Still getting this error with Jenkins LTS 1.509.4 and Subversion plugin version 1.54. Reopen?

          acolichia Aaron Colichia added a comment -

          Still getting this error with Jenkins 1.509.4 and Subversion plugin version 1.54

          acolichia Aaron Colichia made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          egsejenkins Reece Johnston added a comment -

          I'm still seeing this with Jenkins 1.511 and Subversion Plugin 2.4. Is this being worked at all?

          mwebber Matthew Webber added a comment -

          I'm still seeing this with Jenkins 1.511 and Subversion Plugin 2.4. Is this being worked at all?

          If you look at https://wiki.jenkins-ci.org/display/JENKINS/Subversion+Plugin, you will see a note that there are issues with Subversion Plugin 2.4 anyhow (JENKINS-23146), so I suggest dropping back to 2.3. That works for me (with Jenkins 1.569).

          egsejenkins Reece Johnston added a comment - - edited

          I'm aware of the problems. However, I severely need the svnexternals fix that 2.4 introduces.

          recena Manuel Recena Soto made changes -
          Assignee Nicolas De Loof [ ndeloof ] Manuel Jesús Recena Soto [ recena ]
          recena Manuel Recena Soto added a comment - - edited

          Tim Preston, What do you think if we close this issue?

          recena Manuel Recena Soto made changes -
          Priority Blocker [ 1 ] Major [ 3 ]
          tpreston Tim Preston added a comment -

          Manuel Recena Soto, that's fine by me. I haven't encountered this issue for quite some time now.

          recena Manuel Recena Soto added a comment -

          It can not reproduce in the most recent versions.

          recena Manuel Recena Soto made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Cannot Reproduce [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 151117 ] JNJira + In-Review [ 193794 ]

            People

            • Assignee:
              recena Manuel Recena Soto
              Reporter:
              tpreston Tim Preston
            • Votes:
              27 Vote for this issue
              Watchers:
              38 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: