Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20038

saving Configure System page intermittently causes JDK install settings to change

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      I have intermittently seen the 'Configure System' page save action change the JDK install settings.

      I have seen this occur twice now.

      Our JDK install settings are pretty straightforward-- jdk6 – bound to install automatically from java.sun.com, version 6u43, and jdk7 – bound to install automatically from java.sun.com, version 7u40.

      When this occurs, the jdk6 setting ends up pointing to jdk7, which results in a bunch of build failures.

        Attachments

          Issue Links

            Activity

            sroth Steve Roth added a comment -

            Forgot to mention – I've seen this with both Jenkins 1.518 and Jenkins 1.534.

            In neither case did I change (or even view) the JDK settings – I did not click on the JDK installations... button. There's also no visual indication that the change has been made.

            danielbeck Daniel Beck added a comment -

            Steve: When this happens, does it occur after you reload the config page? There are a few known issue related to the config form confusing values if you do that. Never reload a config page, instead, navigate away, and back to the config page (best to not user the browser's back button either).

            danielbeck Daniel Beck added a comment -

            Without response to comment in 2+ weeks, assuming this is a duplicate of JENKINS-18435.


              People

              • Assignee:
                Unassigned
                Reporter:
                sroth Steve Roth
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: