Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20080

Build Button fails for jobs that require "Build with Parameters"

    Details

    • Similar Issues:

      Description

      I just upgraded to 1.535. Handling of jobs that require parameters to build is broken.

      This works:

      • I go to the job page http://jenkins/job/jobname
      • I see an option "Build with Parameters"
      • I click the button, I enter the parameters
      • The job is submitted.

      This doesn't work:

      • I see the job listed on a view page http://jenkins/view/viewname
      • I hover over the "build" button, which displays the hover text "Schedule a build with parameters"
      • I click the button, and expect to enter the parameters, but instead it immediately says "build scheduled", but the job is not actually scheduled.

      Then if I look in the log, I see an exception trace as reported in JENKINS-20074.

        Attachments

          Issue Links

            Activity

            Hide
            mwebber Matthew Webber added a comment -

            See on the jenkinsci-users mailing list:

            I face a similar issue in version 1.531. I have a job (MultiJob Project) that run another set of jobs. From the view I am able to schedule the build, but from the job page I wont be able to start the build even though it says build scheduled after I click it and give parameters.

            This is not same but has same behaviour (JENKINS-20080)

            Vivek.

            Show
            mwebber Matthew Webber added a comment - See on the jenkinsci-users mailing list: I face a similar issue in version 1.531. I have a job (MultiJob Project) that run another set of jobs. From the view I am able to schedule the build, but from the job page I wont be able to start the build even though it says build scheduled after I click it and give parameters. This is not same but has same behaviour ( JENKINS-20080 ) Vivek.
            Hide
            sroth Steve Roth added a comment -

            We just noticed this as well. I think it coincided with the upgrade to 1.535. Will rollback to 1.534 later today and can confirm if that's the case or not.

            Show
            sroth Steve Roth added a comment - We just noticed this as well. I think it coincided with the upgrade to 1.535. Will rollback to 1.534 later today and can confirm if that's the case or not.
            Show
            jglick Jesse Glick added a comment - I think a faulty merge was to blame: https://github.com/jenkinsci/jenkins/commit/82a10c12cedcb48c8583aea3ff7f8db42cbf8331#commitcomment-4349191
            Show
            olivergondza Oliver Gondža added a comment - https://github.com/jenkinsci/jenkins/pull/975
            Hide
            sroth Steve Roth added a comment -

            I believe we're already past this, but in case it's useful, I can confirm that rolling back to 1.534 fixed the issue for us. So it arrived with 1.535.

            Show
            sroth Steve Roth added a comment - I believe we're already past this, but in case it's useful, I can confirm that rolling back to 1.534 fixed the issue for us. So it arrived with 1.535.
            Hide
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oliver Gondža
            Path:
            core/src/main/resources/hudson/views/BuildButtonColumn/column.jelly
            http://jenkins-ci.org/commit/jenkins/245a8bf2c60a63ec1c99bb7833358581ee220b5b
            Log:
            [FIXED JENKINS-20080] Build Button fails for jobs that require "Build with Parameters"

            Show
            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oliver Gondža Path: core/src/main/resources/hudson/views/BuildButtonColumn/column.jelly http://jenkins-ci.org/commit/jenkins/245a8bf2c60a63ec1c99bb7833358581ee220b5b Log: [FIXED JENKINS-20080] Build Button fails for jobs that require "Build with Parameters"
            Hide
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            changelog.html
            http://jenkins-ci.org/commit/jenkins/dea7cfd03920c0989ab058fc5166242ceb33dee6
            Log:
            JENKINS-20080 Noting that pull #975 was merged.

            Compare: https://github.com/jenkinsci/jenkins/compare/aae949ea2101...dea7cfd03920

            Show
            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Jesse Glick Path: changelog.html http://jenkins-ci.org/commit/jenkins/dea7cfd03920c0989ab058fc5166242ceb33dee6 Log: JENKINS-20080 Noting that pull #975 was merged. Compare: https://github.com/jenkinsci/jenkins/compare/aae949ea2101...dea7cfd03920
            Hide
            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #2958
            [FIXED JENKINS-20080] Build Button fails for jobs that require "Build with Parameters" (Revision 245a8bf2c60a63ec1c99bb7833358581ee220b5b)
            JENKINS-20080 Noting that pull #975 was merged. (Revision dea7cfd03920c0989ab058fc5166242ceb33dee6)

            Result = SUCCESS
            ogondza : 245a8bf2c60a63ec1c99bb7833358581ee220b5b
            Files :

            • core/src/main/resources/hudson/views/BuildButtonColumn/column.jelly

            Jesse Glick : dea7cfd03920c0989ab058fc5166242ceb33dee6
            Files :

            • changelog.html
            Show
            dogfood dogfood added a comment - Integrated in jenkins_main_trunk #2958 [FIXED JENKINS-20080] Build Button fails for jobs that require "Build with Parameters" (Revision 245a8bf2c60a63ec1c99bb7833358581ee220b5b) JENKINS-20080 Noting that pull #975 was merged. (Revision dea7cfd03920c0989ab058fc5166242ceb33dee6) Result = SUCCESS ogondza : 245a8bf2c60a63ec1c99bb7833358581ee220b5b Files : core/src/main/resources/hudson/views/BuildButtonColumn/column.jelly Jesse Glick : dea7cfd03920c0989ab058fc5166242ceb33dee6 Files : changelog.html
            Hide
            benza benza added a comment -

            This issue was fixed, you need to upgrade "Jenkins Parameterized Trigger plugin"
            to 2.22 with jenkins > 1.537

            Show
            benza benza added a comment - This issue was fixed, you need to upgrade "Jenkins Parameterized Trigger plugin" to 2.22 with jenkins > 1.537
            Hide
            g1 G Harris added a comment -

            This is still broken in Jenkins 1.551 with Parameterized Trigger plugin 2.22.

            Show
            g1 G Harris added a comment - This is still broken in Jenkins 1.551 with Parameterized Trigger plugin 2.22.
            Hide
            mwebber Matthew Webber added a comment -

            This is still broken in Jenkins 1.551 with Parameterized Trigger plugin 2.22.

            It has not been broken for me since 1.538/2.22. @G Harris, did you only just upgrade and are still seeing the problem? What was the sequence of events?

            Show
            mwebber Matthew Webber added a comment - This is still broken in Jenkins 1.551 with Parameterized Trigger plugin 2.22. It has not been broken for me since 1.538/2.22. @G Harris, did you only just upgrade and are still seeing the problem? What was the sequence of events?
            Hide
            jochen Jochen Pinnekamp added a comment - - edited

            Still seeing this sporadically with Jenkins 1.612 and Trigger 2.27

            Show
            jochen Jochen Pinnekamp added a comment - - edited Still seeing this sporadically with Jenkins 1.612 and Trigger 2.27
            Hide
            olivergondza Oliver Gondža added a comment -

            Jochen Pinnekamp, please file a separate issue, this was fixed almost 2 years ago.

            Show
            olivergondza Oliver Gondža added a comment - Jochen Pinnekamp , please file a separate issue, this was fixed almost 2 years ago.
            Hide
            ram237 Pavel Pigalov added a comment -

            Hi guys,
            Currently experiencing this on:

            • Jenkins v1.653
            • multijob-plugin v1.21

            How to get rid of this?

            Show
            ram237 Pavel Pigalov added a comment - Hi guys, Currently experiencing this on: Jenkins v1.653 multijob-plugin v1.21 How to get rid of this?
            Hide
            olivergondza Oliver Gondža added a comment -

            Pavel Pigalov, please file a separate issue, this was fixed more than 2 years ago.

            Show
            olivergondza Oliver Gondža added a comment - Pavel Pigalov , please file a separate issue, this was fixed more than 2 years ago.
            Hide
            ram237 Pavel Pigalov added a comment -

            Thanks for your reply, Oliver Gondža!
            I've raised JENKINS-34161 - seems to be related to multijob view only.

            Show
            ram237 Pavel Pigalov added a comment - Thanks for your reply, Oliver Gondža ! I've raised JENKINS-34161 - seems to be related to multijob view only.

              People

              • Assignee:
                olivergondza Oliver Gondža
                Reporter:
                mwebber Matthew Webber
              • Votes:
                1 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: