Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20114

"New Job" -> "Freestyle project" -> "OK" - hangs forever

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Hang for a long time and after a minute or two, error messages related to job creation showed up, see attached log.

      Oct 17, 2013 4:52:35 PM com.sonyericsson.hudson.plugins.gerrit.trigger.gerritnotifier.GerritNotifier buildStarted
      INFO: BuildStarted command is empty.  Gerrit will not be notified of BuildStarted
      Oct 17, 2013 4:52:35 PM winstone.Logger logInternal
      WARNING: Untrapped Error in Servlet
      javax.servlet.ServletException: org.apache.commons.jelly.JellyTagException: jar:file:/var/cache/jenkins/war/WEB-INF/lib/jenkins-core-1.531.jar!/lib/layout/layout.jelly:75:72: <st:include> failed to deflate
      	at org.kohsuke.stapler.jelly.JellyFacet$1.dispatch(JellyFacet.java:103)
      	at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:685)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:799)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:587)
      	at hudson.init.impl.InstallUncaughtExceptionHandler$1.reportException(InstallUncaughtExceptionHandler.java:25)
      	at org.kohsuke.stapler.compression.CompressionFilter.reportException(CompressionFilter.java:63)
      	at org.kohsuke.stapler.compression.CompressionFilter.doFilter(CompressionFilter.java:49)
      	at winstone.FilterConfiguration.execute(FilterConfiguration.java:194)
      	at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:366)
      	at hudson.util.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:81)
      	at winstone.FilterConfiguration.execute(FilterConfiguration.java:194)
      	at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:366)
      	at winstone.RequestDispatcher.forward(RequestDispatcher.java:331)
      	at winstone.RequestHandlerThread.processRequest(RequestHandlerThread.java:227)
      	at winstone.RequestHandlerThread.run(RequestHandlerThread.java:150)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at winstone.BoundedExecutorService$1.run(BoundedExecutorService.java:77)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: org.apache.commons.jelly.JellyTagException: jar:file:/var/cache/jenkins/war/WEB-INF/lib/jenkins-core-1.531.jar!/lib/layout/layout.jelly:75:72: <st:include> failed to deflate
      	at org.apache.commons.jelly.impl.TagScript.handleException(TagScript.java:726)
      	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      	at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:161)
      	at org.apache.commons.jelly.tags.core.ForEachTag.doTag(ForEachTag.java:150)
      	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269)
      	at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      	at org.apache.commons.jelly.tags.core.CoreTagLibrary$1.run(CoreTagLibrary.java:98)
      	at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      	at org.apache.commons.jelly.tags.core.CoreTagLibrary$2.run(CoreTagLibrary.java:105)
      	at org.kohsuke.stapler.jelly.CallTagLibScript.run(CallTagLibScript.java:119)
      	at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      	at org.apache.commons.jelly.tags.core.CoreTagLibrary$2.run(CoreTagLibrary.java:105)
      	at org.kohsuke.stapler.jelly.JellyViewScript.run(JellyViewScript.java:81)
      	at org.kohsuke.stapler.jelly.DefaultScriptInvoker.invokeScript(DefaultScriptInvoker.java:63)
      	at org.kohsuke.stapler.jelly.DefaultScriptInvoker.invokeScript(DefaultScriptInvoker.java:53)
      	at org.kohsuke.stapler.jelly.JellyFacet$1.dispatch(JellyFacet.java:95)
      	... 21 more
      Caused by: java.io.IOException: failed to deflate
      	at com.jcraft.jzlib.DeflaterOutputStream.deflate(DeflaterOutputStream.java:140)
      	at com.jcraft.jzlib.DeflaterOutputStream.write(DeflaterOutputStream.java:102)
      	at org.kohsuke.stapler.compression.FilterServletOutputStream.write(FilterServletOutputStream.java:31)
      	at org.kohsuke.stapler.jelly.DefaultScriptInvoker$1.write(DefaultScriptInvoker.java:99)
      	at sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:220)
      	at sun.nio.cs.StreamEncoder.implFlushBuffer(StreamEncoder.java:290)
      	at sun.nio.cs.StreamEncoder.implFlush(StreamEncoder.java:294)
      	at sun.nio.cs.StreamEncoder.flush(StreamEncoder.java:140)
      	at java.io.OutputStreamWriter.flush(OutputStreamWriter.java:229)
      	at java.io.BufferedWriter.flush(BufferedWriter.java:253)
      	at org.dom4j.io.XMLWriter.flush(XMLWriter.java:276)
      	at org.apache.commons.jelly.XMLOutput.flush(XMLOutput.java:127)
      	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:271)
      	... 35 more
      Oct 17, 2013 4:52:35 PM winstone.Logger logInternal
      WARNING: Untrapped Error in Servlet
      javax.servlet.ServletException: org.apache.commons.jelly.JellyTagException: jar:file:/var/cache/jenkins/war/WEB-INF/lib/jenkins-core-1.531.jar!/lib/layout/layout.jelly:75:72: <st:include> failed to deflate
      	at org.kohsuke.stapler.jelly.JellyFacet$1.dispatch(JellyFacet.java:103)
      	at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:685)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:799)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:587)
      	at hudson.init.impl.InstallUncaughtExceptionHandler$1.reportException(InstallUncaughtExceptionHandler.java:25)
      	at org.kohsuke.stapler.compression.CompressionFilter.reportException(CompressionFilter.java:63)
      	at org.kohsuke.stapler.compression.CompressionFilter.doFilter(CompressionFilter.java:49)
      	at winstone.FilterConfiguration.execute(FilterConfiguration.java:194)
      	at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:366)
      	at hudson.util.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:81)
      	at winstone.FilterConfiguration.execute(FilterConfiguration.java:194)
      	at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:366)
      	at winstone.RequestDispatcher.forward(RequestDispatcher.java:331)
      	at winstone.RequestHandlerThread.processRequest(RequestHandlerThread.java:227)
      	at winstone.RequestHandlerThread.run(RequestHandlerThread.java:150)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at winstone.BoundedExecutorService$1.run(BoundedExecutorService.java:77)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: org.apache.commons.jelly.JellyTagException: jar:file:/var/cache/jenkins/war/WEB-INF/lib/jenkins-core-1.531.jar!/lib/layout/layout.jelly:75:72: <st:include> failed to deflate
      	at org.apache.commons.jelly.impl.TagScript.handleException(TagScript.java:726)
      	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      	at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:161)
      	at org.apache.commons.jelly.tags.core.ForEachTag.doTag(ForEachTag.java:150)
      	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269)
      	at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      	at org.apache.commons.jelly.tags.core.CoreTagLibrary$1.run(CoreTagLibrary.java:98)
      	at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      	at org.apache.commons.jelly.tags.core.CoreTagLibrary$2.run(CoreTagLibrary.java:105)
      	at org.kohsuke.stapler.jelly.CallTagLibScript.run(CallTagLibScript.java:119)
      	at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      	at org.apache.commons.jelly.tags.core.CoreTagLibrary$2.run(CoreTagLibrary.java:105)
      	at org.kohsuke.stapler.jelly.JellyViewScript.run(JellyViewScript.java:81)
      	at org.kohsuke.stapler.jelly.DefaultScriptInvoker.invokeScript(DefaultScriptInvoker.java:63)
      	at org.kohsuke.stapler.jelly.DefaultScriptInvoker.invokeScript(DefaultScriptInvoker.java:53)
      	at org.kohsuke.stapler.jelly.JellyFacet$1.dispatch(JellyFacet.java:95)
      	... 21 more
      Caused by: java.io.IOException: failed to deflate
      	at com.jcraft.jzlib.DeflaterOutputStream.deflate(DeflaterOutputStream.java:140)
      	at com.jcraft.jzlib.DeflaterOutputStream.write(DeflaterOutputStream.java:102)
      	at org.kohsuke.stapler.compression.FilterServletOutputStream.write(FilterServletOutputStream.java:31)
      	at org.kohsuke.stapler.jelly.DefaultScriptInvoker$1.write(DefaultScriptInvoker.java:99)
      	at sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:220)
      	at sun.nio.cs.StreamEncoder.implFlushBuffer(StreamEncoder.java:290)
      	at sun.nio.cs.StreamEncoder.implFlush(StreamEncoder.java:294)
      	at sun.nio.cs.StreamEncoder.flush(StreamEncoder.java:140)
      	at java.io.OutputStreamWriter.flush(OutputStreamWriter.java:229)
      	at java.io.BufferedWriter.flush(BufferedWriter.java:253)
      	at org.dom4j.io.XMLWriter.flush(XMLWriter.java:276)
      	at org.apache.commons.jelly.XMLOutput.flush(XMLOutput.java:127)
      	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:271)
      	... 35 more
      Oct 17, 2013 4:52:35 PM winstone.Logger logInternal
      WARNING: Untrapped Error in Servlet
      javax.servlet.ServletException: org.apache.commons.jelly.JellyTagException: jar:file:/var/cache/jenkins/war/WEB-INF/lib/jenkins-core-1.531.jar!/lib/layout/layout.jelly:75:72: <st:include> failed to deflate
      	at org.kohsuke.stapler.jelly.JellyFacet$1.dispatch(JellyFacet.java:103)
      	at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:685)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:799)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:587)
      	at hudson.init.impl.InstallUncaughtExceptionHandler$1.reportException(InstallUncaughtExceptionHandler.java:25)
      	at org.kohsuke.stapler.compression.CompressionFilter.reportException(CompressionFilter.java:63)
      	at org.kohsuke.stapler.compression.CompressionFilter.doFilter(CompressionFilter.java:49)
      	at winstone.FilterConfiguration.execute(FilterConfiguration.java:194)
      	at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:366)
      	at hudson.util.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:81)
      	at winstone.FilterConfiguration.execute(FilterConfiguration.java:194)
      	at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:366)
      	at winstone.RequestDispatcher.forward(RequestDispatcher.java:331)
      	at winstone.RequestHandlerThread.processRequest(RequestHandlerThread.java:227)
      	at winstone.RequestHandlerThread.run(RequestHandlerThread.java:150)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at winstone.BoundedExecutorService$1.run(BoundedExecutorService.java:77)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: org.apache.commons.jelly.JellyTagException: jar:file:/var/cache/jenkins/war/WEB-INF/lib/jenkins-core-1.531.jar!/lib/layout/layout.jelly:75:72: <st:include> failed to deflate
      	at org.apache.commons.jelly.impl.TagScript.handleException(TagScript.java:726)
      	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      	at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:161)
      	at org.apache.commons.jelly.tags.core.ForEachTag.doTag(ForEachTag.java:150)
      	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:269)
      	at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      	at org.apache.commons.jelly.tags.core.CoreTagLibrary$1.run(CoreTagLibrary.java:98)
      	at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      	at org.apache.commons.jelly.tags.core.CoreTagLibrary$2.run(CoreTagLibrary.java:105)
      	at org.kohsuke.stapler.jelly.CallTagLibScript.run(CallTagLibScript.java:119)
      	at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      	at org.apache.commons.jelly.tags.core.CoreTagLibrary$2.run(CoreTagLibrary.java:105)
      	at org.kohsuke.stapler.jelly.JellyViewScript.run(JellyViewScript.java:81)
      	at org.kohsuke.stapler.jelly.DefaultScriptInvoker.invokeScript(DefaultScriptInvoker.java:63)
      	at org.kohsuke.stapler.jelly.DefaultScriptInvoker.invokeScript(DefaultScriptInvoker.java:53)
      	at org.kohsuke.stapler.jelly.JellyFacet$1.dispatch(JellyFacet.java:95)
      	... 21 more
      Caused by: java.io.IOException: failed to deflate
      	at com.jcraft.jzlib.DeflaterOutputStream.deflate(DeflaterOutputStream.java:140)
      	at com.jcraft.jzlib.DeflaterOutputStream.write(DeflaterOutputStream.java:102)
      	at org.kohsuke.stapler.compression.FilterServletOutputStream.write(FilterServletOutputStream.java:31)
      	at org.kohsuke.stapler.jelly.DefaultScriptInvoker$1.write(DefaultScriptInvoker.java:99)
      	at sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:220)
      	at sun.nio.cs.StreamEncoder.implFlushBuffer(StreamEncoder.java:290)
      	at sun.nio.cs.StreamEncoder.implFlush(StreamEncoder.java:294)
      	at sun.nio.cs.StreamEncoder.flush(StreamEncoder.java:140)
      	at java.io.OutputStreamWriter.flush(OutputStreamWriter.java:229)
      	at java.io.BufferedWriter.flush(BufferedWriter.java:253)
      	at org.dom4j.io.XMLWriter.flush(XMLWriter.java:276)
      	at org.apache.commons.jelly.XMLOutput.flush(XMLOutput.java:127)
      	at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:271)
      	... 35 more
      Oct 17, 2013 4:52:35 PM winstone.Logger logInternal
      INFO: While serving http://127.0.0.1:8080/view/Overview/createItem: hudson.security.AccessDeniedException2: anonymous is missing the Job/Create permission
      Oct 17, 2013 4:52:35 PM winstone.Logger logInternal
      INFO: While serving http://127.0.0.1:8080/view/Overview/createItem: hudson.security.AccessDeniedException2: anonymous is missing the Job/Create permission
      Oct 17, 2013 4:52:35 PM winstone.Logger logInternal
      SEVERE: Error in the error servlet
      javax.servlet.ServletException: hudson.security.AccessDeniedException2: anonymous is missing the Job/Create permission
      	at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:735)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:799)
      	at org.kohsuke.stapler.MetaClass$6.doDispatch(MetaClass.java:239)
      	at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:53)
      	at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:685)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:799)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:587)
      	at org.kohsuke.stapler.Stapler.service(Stapler.java:218)
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:45)
      	at winstone.ServletConfiguration.execute(ServletConfiguration.java:248)
      	at winstone.RequestDispatcher.include(RequestDispatcher.java:199)
      	at winstone.RequestHandlerThread.processRequest(RequestHandlerThread.java:251)
      	at winstone.RequestHandlerThread.run(RequestHandlerThread.java:150)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at winstone.BoundedExecutorService$1.run(BoundedExecutorService.java:77)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: hudson.security.AccessDeniedException2: anonymous is missing the Job/Create permission
      	at hudson.security.ACL.checkPermission(ACL.java:54)
      	at hudson.model.Node.checkPermission(Node.java:418)
      	at hudson.model.ItemGroupMixIn.createTopLevelItem(ItemGroupMixIn.java:123)
      	at jenkins.model.Jenkins.doCreateItem(Jenkins.java:2893)
      	at jenkins.model.Jenkins.doCreateItem(Jenkins.java:312)
      	at hudson.model.ListView.doCreateItem(ListView.java:262)
      	at sun.reflect.GeneratedMethodAccessor13472.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:616)
      	at org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:297)
      	at org.kohsuke.stapler.Function.bindAndInvoke(Function.java:160)
      	at org.kohsuke.stapler.Function.bindAndInvokeAndServeResponse(Function.java:95)
      	at org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:111)
      	at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:53)
      	at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:685)
      	... 19 more
      Oct 17, 2013 4:52:35 PM winstone.Logger logInternal
      SEVERE: Error in the error servlet
      javax.servlet.ServletException: hudson.security.AccessDeniedException2: anonymous is missing the Job/Create permission
      	at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:735)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:799)
      	at org.kohsuke.stapler.MetaClass$6.doDispatch(MetaClass.java:239)
      	at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:53)
      	at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:685)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:799)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:587)
      	at org.kohsuke.stapler.Stapler.service(Stapler.java:218)
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:45)
      	at winstone.ServletConfiguration.execute(ServletConfiguration.java:248)
      	at winstone.RequestDispatcher.include(RequestDispatcher.java:199)
      	at winstone.RequestHandlerThread.processRequest(RequestHandlerThread.java:251)
      	at winstone.RequestHandlerThread.run(RequestHandlerThread.java:150)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at winstone.BoundedExecutorService$1.run(BoundedExecutorService.java:77)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: hudson.security.AccessDeniedException2: anonymous is missing the Job/Create permission
      	at hudson.security.ACL.checkPermission(ACL.java:54)
      	at hudson.model.Node.checkPermission(Node.java:418)
      	at hudson.model.ItemGroupMixIn.createTopLevelItem(ItemGroupMixIn.java:123)
      	at jenkins.model.Jenkins.doCreateItem(Jenkins.java:2893)
      	at jenkins.model.Jenkins.doCreateItem(Jenkins.java:312)
      	at hudson.model.ListView.doCreateItem(ListView.java:262)
      	at sun.reflect.GeneratedMethodAccessor13472.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:616)
      	at org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:297)
      	at org.kohsuke.stapler.Function.bindAndInvoke(Function.java:160)
      	at org.kohsuke.stapler.Function.bindAndInvokeAndServeResponse(Function.java:95)
      	at org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:111)
      	at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:53)
      	at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:685)
      	... 19 more
      Oct 17, 2013 4:52:36 PM winstone.Logger logInternal
      INFO: While serving http://127.0.0.1:8080/view/Overview/createItem: hudson.security.AccessDeniedException2: anonymous is missing the Job/Create permission
      Oct 17, 2013 4:52:36 PM winstone.Logger logInternal
      SEVERE: Error in the error servlet
      javax.servlet.ServletException: hudson.security.AccessDeniedException2: anonymous is missing the Job/Create permission
      	at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:735)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:799)
      	at org.kohsuke.stapler.MetaClass$6.doDispatch(MetaClass.java:239)
      	at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:53)
      	at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:685)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:799)
      	at org.kohsuke.stapler.Stapler.invoke(Stapler.java:587)
      	at org.kohsuke.stapler.Stapler.service(Stapler.java:218)
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:45)
      	at winstone.ServletConfiguration.execute(ServletConfiguration.java:248)
      	at winstone.RequestDispatcher.include(RequestDispatcher.java:199)
      	at winstone.RequestHandlerThread.processRequest(RequestHandlerThread.java:251)
      	at winstone.RequestHandlerThread.run(RequestHandlerThread.java:150)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at winstone.BoundedExecutorService$1.run(BoundedExecutorService.java:77)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: hudson.security.AccessDeniedException2: anonymous is missing the Job/Create permission
      	at hudson.security.ACL.checkPermission(ACL.java:54)
      	at hudson.model.Node.checkPermission(Node.java:418)
      	at hudson.model.ItemGroupMixIn.createTopLevelItem(ItemGroupMixIn.java:123)
      	at jenkins.model.Jenkins.doCreateItem(Jenkins.java:2893)
      	at jenkins.model.Jenkins.doCreateItem(Jenkins.java:312)
      	at hudson.model.ListView.doCreateItem(ListView.java:262)
      	at sun.reflect.GeneratedMethodAccessor13472.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:616)
      	at org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:297)
      	at org.kohsuke.stapler.Function.bindAndInvoke(Function.java:160)
      	at org.kohsuke.stapler.Function.bindAndInvokeAndServeResponse(Function.java:95)
      	at org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:111)
      	at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:53)
      	at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:685)
      	... 19 more
      

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev added a comment -

            Seems to be a duplicate of JENKINS-20618

            oleg_nenashev Oleg Nenashev added a comment - - edited

            <del>

            oleg_nenashev Oleg Nenashev added a comment -

            Closing as a duplicate of JENKINS-20074. "AccessDenied" may be caused by the session timeout during the waiting.
            Please re-open the issue if it appears in newer versions.


              People

              • Assignee:
                Unassigned
                Reporter:
                samxiao Sam Xiao
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: