Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20138

swarm 1.9 can't connect to current LTS as slave.jar too old

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: swarm-plugin
    • Labels:
    • Environment:
      Master: CentOS 6
      Slaves: CentOS 6
      Java: OpenJDK 1.7.0_25
    • Similar Issues:

      Description

      Using the 1.9 version of the swarm plugin to connect to LTS 1.509.4 fails because the embedded slave.jar (version 2.12) is too old
      Current slave.jar version in LTS 1.509.4 is 2.32

      The initial connection works but the slave soon disconnects with 'slave too old' displayed in the GUI.

        Attachments

          Activity

          bdellegrazie Brett Delle Grazie created issue -
          sogabe sogabe made changes -
          Field Original Value New Value
          Assignee Kohsuke Kawaguchi [ kohsuke ] sogabe [ sogabe ]
          scm_issue_link SCM/JIRA link daemon made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          markewaite Mark Waite made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 151660 ] JNJira + In-Review [ 207051 ]

            People

            • Assignee:
              sogabe sogabe
              Reporter:
              bdellegrazie Brett Delle Grazie
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: