Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20155

Select All in /pluginManager/ should not select plugins with a compatWarning

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      When a plugin shows a <div class="compatWarning">, users asking to just install "all" updates should not get this one. (So something other than toggleCheckboxes must be used.) They should need to explicitly check it. Currently people are quite likely to install plugins which do not in fact work with their current core.

      Alternately, the two Install buttons should show a warning dialog before proceeding in case you have selected one or more plugins thought to be incompatible with your current Jenkins version.

      The same considerations may also apply to plugins marked with Compatible-Since-Version.

        Attachments

          Issue Links

            Activity

            Hide
            xxyy Philipp Nowak added a comment -
            Show
            xxyy Philipp Nowak added a comment - Proposed PR for this issue:  https://github.com/jenkinsci/jenkins/pull/3715

              People

              • Assignee:
                Unassigned
                Reporter:
                jglick Jesse Glick
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: