Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20187

TarArchiver.visit produces corrupt archive when file size changes during write

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      TarArchiver.visit assumes that the input stream from a file is of the exact length as .length() reported when it started. This may not be true for things like log files that are frequently appended to. That can cause corruption of artifact archiving, backups, etc.

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Jesse: Isn't this a duplicate of JENKINS-7695?

            jglick Jesse Glick added a comment -

            Yes, though this one has a more useful summary.

            jglick Jesse Glick added a comment -

            And link to JENKINS-21426, which is related and should probably be fixed in the same commit.

            alobato Alvaro Lobato added a comment -

            Created PR-2419 with a proposed fix.


              People

              • Assignee:
                alobato Alvaro Lobato
                Reporter:
                jglick Jesse Glick
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: