Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20189

git can't clone but doesn't ever call git clone

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      Linux RHEL 6.4
    • Similar Issues:

      Description

      For some reason I can't clone or update git jobs after updating to Jenkins 1.536. I can see that it calls git --version but it never seems to call git clone. I've verified this by wrapping the git command with a shell script to log it. I've blown away the workspace and had Jenkins rebuild it, still produces the same git error.

      Last Built Revision: Revision 1480f9f672147b2e1b7daad55dc74048fa977bf1 (origin/master)
      Cloning the remote Git repository
      Cloning repository https://github.com/EMSL-MSC/go-rpms.git
      git --version
      git version 1.7.1
      ERROR: Error cloning remote repo 'origin' : Could not clone https://github.com/EMSL-MSC/go-rpms.git
      hudson.plugins.git.GitException: Could not clone https://github.com/EMSL-MSC/go-rpms.git
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl$1.execute(CliGitAPIImpl.java:286)
      at org.jenkinsci.plugins.gitclient.AbstractGitAPIImpl.clone(AbstractGitAPIImpl.java:59)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.clone(CliGitAPIImpl.java:47)
      at hudson.plugins.git.GitSCM$2.invoke(GitSCM.java:1012)
      at hudson.plugins.git.GitSCM$2.invoke(GitSCM.java:948)
      at hudson.FilePath.act(FilePath.java:912)
      at hudson.FilePath.act(FilePath.java:885)
      at hudson.plugins.git.GitSCM.determineRevisionToBuild(GitSCM.java:948)
      at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1114)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1411)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:652)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:557)
      at hudson.model.Run.execute(Run.java:1665)
      at hudson.matrix.MatrixBuild.run(MatrixBuild.java:304)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:230)
      at hudson.model.OneOffExecutor.run(OneOffExecutor.java:43)
      Caused by: hudson.plugins.git.GitException: Failed to connect to https://github.com/EMSL-MSC/go-rpms.git
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.getURLWithCrendentials(CliGitAPIImpl.java:1374)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.getURLWithCrendentials(CliGitAPIImpl.java:1326)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.access$300(CliGitAPIImpl.java:47)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl$1.execute(CliGitAPIImpl.java:280)
      ... 17 more
      Trying next repository
      ERROR: Could not clone repository
      java.io.IOException: Could not clone
      at hudson.plugins.git.GitSCM$2.invoke(GitSCM.java:1025)
      at hudson.plugins.git.GitSCM$2.invoke(GitSCM.java:948)
      at hudson.FilePath.act(FilePath.java:912)
      at hudson.FilePath.act(FilePath.java:885)
      at hudson.plugins.git.GitSCM.determineRevisionToBuild(GitSCM.java:948)
      at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1114)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1411)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:652)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:557)
      at hudson.model.Run.execute(Run.java:1665)
      at hudson.matrix.MatrixBuild.run(MatrixBuild.java:304)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:230)
      at hudson.model.OneOffExecutor.run(OneOffExecutor.java:43)
      Finished: FAILURE

        Attachments

          Activity

          rmsilva Ricardo Silva added a comment -

          Thanks for the update on the .git aside. But it was an aside, the original issue that 'git clone' doesn't work with git client versions above 1.4.0 (in my case) is still true.

          (The title is a bit misleading but the problem exists.)

          markewaite Mark Waite added a comment -

          This was marked "Resolved" some time ago. Now marking it "Closed" since there is

          danielbeck Daniel Beck added a comment -

          Mark Waite Preceding comment is incomplete.

          markewaite Mark Waite added a comment -

          Jira for that comment does not allow me to edit the comment. The comment should have said that I am marking it Closed since git versions prior to 1.7.10 do not support credentials, and credentials are now a key part of the git plugin use model.

          danielbeck Daniel Beck added a comment -

          Mark Waite:

          Jira for that comment does not allow me to edit the comment

          Probably thanks to 'Closed' status, just like it doesn't allow editing the issue. Hoping for INFRA-119.


            People

            • Assignee:
              ndeloof Nicolas De Loof
              Reporter:
              dmlb2000 David Brown
            • Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: