Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20192

CVS Plugin crashes in matrix job on slave machines

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: cvs-plugin
    • Labels:
    • Environment:
      Jenkins CVS Plug-in 2.10; Jenkins 1.536; OSX 10.7.5
    • Similar Issues:

      Description

      cvs rlog crashes on all slaves of a matrix job (except when the slave is the same as the master):

      cvs rlog -S -d22 Oct 2013 10:41:01 -0600<22 Oct 2013 11:04:09 -0600 MyProject
      hudson.util.IOException2: remote file operation failed: C:\Users\admin\.jenkins\workspace\Project\label\windows at hudson.remoting.Channel@591e356b:WinBuilder1
      at hudson.FilePath.act(FilePath.java:908)
      at hudson.FilePath.act(FilePath.java:885)
      at hudson.scm.AbstractCvs.getRemoteLogForModule(AbstractCvs.java:678)
      at hudson.scm.AbstractCvs.calculateChangeLog(AbstractCvs.java:774)
      at hudson.scm.AbstractCvs.postCheckout(AbstractCvs.java:793)
      at hudson.scm.CVSSCM.checkout(CVSSCM.java:351)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1411)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:652)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:557)
      at hudson.model.Run.execute(Run.java:1665)
      at hudson.matrix.MatrixRun.run(MatrixRun.java:146)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:230)
      Caused by: java.io.IOException: Unable to serialize hudson.FilePath$FileCallableWrapper@573b8157
      at hudson.remoting.UserRequest.serialize(UserRequest.java:166)
      at hudson.remoting.UserRequest.<init>(UserRequest.java:62)
      at hudson.remoting.Channel.call(Channel.java:713)
      at hudson.FilePath.act(FilePath.java:901)
      ... 13 more
      Caused by: java.io.NotSerializableException: java.io.PrintStream
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1164)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1518)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1483)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1400)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1158)
      at java.io.ObjectOutputStream.writeArray(ObjectOutputStream.java:1346)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1154)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1518)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1483)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1400)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1158)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1518)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1483)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1400)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1158)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1518)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1483)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1400)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1158)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1518)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1483)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1400)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1158)
      at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:330)
      at hudson.remoting.UserRequest._serialize(UserRequest.java:155)
      at hudson.remoting.UserRequest.serialize(UserRequest.java:164)

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Michael Clarke
          Path:
          src/main/java/hudson/scm/CVSChangeLogSet.java
          http://jenkins-ci.org/commit/cvs-plugin/39502b660f745d04bd608a40cfb6517d5ea716fc
          Log:
          JENKINS-20192 don't attempt to build user during internal comparison

          mc1arke Michael Clarke added a comment -

          Simon: nice guess, but not right. User will return null if the provided username is null (although will create a user when an unknown username is provided), but that's not the issue we're seeing.

          I've made a change to compare usernames rather than whole users (since these can't be built on slaves in never Jenkins versions) during changelog generation which is now available in the latest snapshot (https://jenkins.ci.cloudbees.com/job/plugins/job/cvs-plugin/201/org.jenkins-ci.plugins$cvs/artifact/org.jenkins-ci.plugins/cvs/2.11-SNAPSHOT/cvs-2.11-SNAPSHOT.hpi). Could one of you try that.

          12delta Simon Strauch added a comment -

          I am Sorry. This evening, it is not possible for me to test the snapshot. (My team members need Jenkins.) May be I can test it tomorrow afternoon/evening (GMT+2).

          12delta Simon Strauch added a comment -
          cscooper Chris Shearer Cooper added a comment -

          Agreed, snapshot from build #202 is a go!


            People

            • Assignee:
              mc1arke Michael Clarke
              Reporter:
              cscooper Chris Shearer Cooper
            • Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: