Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20209

Maven plugin sends email notification to null address

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      If you have configured your job to send an email notification on build fails and you do a new build, the email will be sent to the address(es) you specified and also to null, i.e "Sending e-mails to: your-mail@gmail.com null". Resulting in a mailer-daemon-mail on every build.

      This wasn't the case on 2.0-beta1 version, it appeared in 2.0 version.

      It could be an effect of JENKINS-19352 and/or JENKINS-1201.

        Attachments

          Issue Links

            Activity

            Hide
            dmitry_baburkin Dmitry Baburkin added a comment -

            Kutzi, for some reason, Jenkins doesn't show that I can upgrade from 2.0 to 2.1.

            Show
            dmitry_baburkin Dmitry Baburkin added a comment - Kutzi, for some reason, Jenkins doesn't show that I can upgrade from 2.0 to 2.1.
            Hide
            gboucherie Guillaume Boucherie added a comment -

            Hi, the 2.1 version of Maven plugin required Jenkins 1.538 so I can't install it on LTS (1.532.1).
            It is possible to make a version with this bugfix compatible for Jenkins version 1.532.1 ?
            Thanks

            Show
            gboucherie Guillaume Boucherie added a comment - Hi, the 2.1 version of Maven plugin required Jenkins 1.538 so I can't install it on LTS (1.532.1). It is possible to make a version with this bugfix compatible for Jenkins version 1.532.1 ? Thanks
            Hide
            jglick Jesse Glick added a comment -

            @gboucherie asks

            It is possible to make a version with this bugfix compatible for Jenkins version 1.532.1?

            See https://github.com/jenkinsci/maven-plugin/commit/e01eb60574c45b6c16091bfd91a05aa36071df68#commitcomment-4588286 and CC @olivergondza.

            Show
            jglick Jesse Glick added a comment - @gboucherie asks It is possible to make a version with this bugfix compatible for Jenkins version 1.532.1? See https://github.com/jenkinsci/maven-plugin/commit/e01eb60574c45b6c16091bfd91a05aa36071df68#commitcomment-4588286 and CC @olivergondza.
            Hide
            dmitry_baburkin Dmitry Baburkin added a comment -

            Thanks guys, 2.0.1 worked for LTS 1.532.1

            Show
            dmitry_baburkin Dmitry Baburkin added a comment - Thanks guys, 2.0.1 worked for LTS 1.532.1
            Hide
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oliver Gondža
            Path:
            src/main/java/org/jenkinsci/test/acceptance/Matchers.java
            src/main/java/org/jenkinsci/test/acceptance/utils/mail/MailService.java
            src/test/java/plugins/MavenPluginTest.java
            http://jenkins-ci.org/commit/acceptance-test-harness/a4878c700d0fab5db68c33b93701f0658a1c54f6
            Log:
            Reproduce JENKINS-20209 and JENKINS-21045

            Compare: https://github.com/jenkinsci/acceptance-test-harness/compare/f6d1423b7335...a4878c700d0f

            Show
            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oliver Gondža Path: src/main/java/org/jenkinsci/test/acceptance/Matchers.java src/main/java/org/jenkinsci/test/acceptance/utils/mail/MailService.java src/test/java/plugins/MavenPluginTest.java http://jenkins-ci.org/commit/acceptance-test-harness/a4878c700d0fab5db68c33b93701f0658a1c54f6 Log: Reproduce JENKINS-20209 and JENKINS-21045 Compare: https://github.com/jenkinsci/acceptance-test-harness/compare/f6d1423b7335...a4878c700d0f

              People

              • Assignee:
                mrebasti Marcelo Rebasti
                Reporter:
                nacken Andreas Magnusson
              • Votes:
                0 Vote for this issue
                Watchers:
                21 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: