Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20339

Found 0 automated test cases in TestLink

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: testlink-plugin
    • Labels:
    • Environment:
      Jenkins ver. 1.474
      TestLink 1.9.8 (Lobizon)
      Jenkins TestLink Plugin 3.7
    • Similar Issues:

      Description

      I configured a sample testlink test plan that includes an automatic test.
      In TestLink "Test Plan Management" the value "Test Case Qty" is not zero.
      I configured a sandbox job, see attachment config.xml.
      During the execution (see log attached) it says me that no atomated test cases is found in TestLink.
      What is going wrong?

        Attachments

        1. config.xml
          3 kB
        2. log
          2 kB

          Activity

          sbartels Sascha Bartels added a comment -

          I have this problem, too. But I found out, that if you execute the test case manually in testlink (just create a build, click "test executing" and mark each test case in your test plan as "ok"), the testlink plugin gets all the test cases from the plan with the next run of the jenkins job.

          ab_ing A B added a comment -

          Thanx. It works.

          However, the issue is not resolved - it is just a workaround.

          kinow Bruno P. Kinoshita added a comment -

          Thanks for the feedback @A B. A new version will get rolled out as soon as I get time to start a new dev cycle to work in the plug-in again.

          kinow Bruno P. Kinoshita added a comment -

          @Sascha, it makes sense I think. The issue is happening because the plug-in added an option to filter by execution status (which was changed in the latest releases of the TestLink XML-RPC). I'll remove this feature and cut a new release. The alpha version was an experiment where I removed this feature from the core code, but not from the UI and other classes. Thanks!

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Bruno P. Kinoshita
          Path:
          src/main/java/hudson/plugins/testlink/AbstractTestLinkBuilder.java
          src/main/java/hudson/plugins/testlink/GraphHelper.java
          src/main/java/hudson/plugins/testlink/TestLinkBuildAction.java
          src/main/java/hudson/plugins/testlink/TestLinkBuilder.java
          src/main/java/hudson/plugins/testlink/TestLinkBuilderDescriptor.java
          src/main/java/hudson/plugins/testlink/TestLinkInstallation.java
          src/main/java/hudson/plugins/testlink/TestLinkProjectAction.java
          src/main/java/hudson/plugins/testlink/TestLinkResult.java
          src/main/java/hudson/plugins/testlink/TestLinkSite.java
          src/main/java/hudson/plugins/testlink/util/TestLinkHelper.java
          src/main/resources/hudson/plugins/testlink/TestLinkBuilder/config.jelly
          src/test/java/hudson/plugins/testlink/TestTestLinkBuilder.java
          src/test/java/hudson/plugins/testlink/TestTestLinkSite.java
          http://jenkins-ci.org/commit/testlink-plugin/1f80f15ffcead970500f31f2333af09bef6af43b
          Log:
          [FIXED JENKINS-20339] reverting pull request 5, which enables Jenkins to filter by execution status

          kinow Bruno P. Kinoshita added a comment -

          3.8 released!


            People

            • Assignee:
              kinow Bruno P. Kinoshita
              Reporter:
              ab_ing A B
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: