Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-203

Table sort setting should be persisted

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:
      Show 5 results

      Description

      Various tables that Hudson displays are all sortable. It would be nice if the
      current sort order is retained in cookie, so that the setting will be carried
      over even if the user leaves the current page.

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 260 has been marked as a duplicate of this issue. ***
            jameslivingston jameslivingston added a comment -

            As well as leaving the page, it'd be nice if it didn't reset the sort order when
            you had page auto-refresh on.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 2514 has been marked as a duplicate of this issue. ***
            mdonohue mdonohue added a comment -
                • Issue 2949 has been marked as a duplicate of this issue. ***
            evensonic Darren Evenson added a comment -

            I think losing the sort on auto-refresh should be a separate issue from maintaining the sort when navigating away and coming back.

            Remembering the sort when returning to page is a nice-to-have. Losing the sort on auto-refresh is a bug IMO.

            Also, retaining the sort on auto refresh could be accomplished without using a cookie, for example a URL query string parameter. Or the items that need refreshing could be refreshed via AJAX versus refreshing the whole page.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: OHTAKE Tomohiro
            Path:
            changelog.html
            core/src/main/resources/lib/layout/layout.jelly
            war/src/main/webapp/scripts/sortable.js
            http://jenkins-ci.org/commit/jenkins/675902a84c7cda6d1d8bc70f9da1d070b5f20904
            Log:
            [FIXED JENKINS-203] Store sortable table state into local storage.

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #1150
            [FIXED JENKINS-203] Store sortable table state into local storage.

            Kohsuke Kawaguchi : 675902a84c7cda6d1d8bc70f9da1d070b5f20904
            Files :

            • core/src/main/resources/lib/layout/layout.jelly
            • war/src/main/webapp/scripts/sortable.js
            • changelog.html

              People

              • Assignee:
                Unassigned
                Reporter:
                kohsuke Kohsuke Kawaguchi
              • Votes:
                16 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: