Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2053

The 'Tag this build action' should have configurable user/password

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Platform: PC, OS: All
    • Similar Issues:

      Description

      Tagging a build with subversion assumes that the credentials are known (or
      predefined by the current user) in Hudson. This does not work on my machine
      (Windows Server). Even if I start tomcat/hudson under my user, Hudson does not
      use the credentials stored in the subversion profile.

      While this seems to be a bug I would better recommend to add a user/password box
      on the tag this build page since it makes sense to run the svn tag (i.e., copy)
      command with a configurable user ID (e.g., a release manager).

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            Is this a situation where you allow anonymous read access but the commit is
            access controlled?

            drulli Ulli Hafner added a comment -

            Yes, that is exactly our setup.

            I noticed that Hudson provides a (hidden) way to specify the credentials in the
            configuration section. I tried using that way but that didn't work either. (But
            this might be a different bug: After setting up our new repository with no
            anonymous access I didn't manage it to checkout the files with Hudson using the
            HTTPS protcol of subversion. I'll add another issue for this.)

            bbrouwer Bruce Brouwer added a comment -

            I have the exact same scenario as well. But rather than configuring a "tagging"
            user code and password, I would prefer to have an option on the same screen
            where I provide the tag name to also have some text fields for providing the
            user and password to use when tagging the build. The appearance of these fields
            could be accomplished with a checkbox on the repository setup section with some
            other options that might look something like this:

            x This repository requires alternate credentials for tagging
            o Prompt for user and password when tagging
            o Use this user when tagging
            User ___________
            Password ___________

            Actually, I have the same situation for CVS as Subversion. For CVS, we've setup
            a will known user called "cvsuser" with a well known password. We use this user
            for all our builds and any read-only access. It would be nice to have the same
            option in this situation as well.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/plugins/subversion/src/main/resources/hudson/scm/SubversionSCM/DescriptorImpl/enterCredential.jelly
            trunk/hudson/plugins/subversion/src/main/resources/hudson/scm/SubversionSCM/DescriptorImpl/enterCredential_fr.properties
            trunk/hudson/plugins/subversion/src/main/resources/hudson/scm/SubversionSCM/DescriptorImpl/enterCredential_ja.properties
            trunk/hudson/plugins/subversion/src/main/resources/hudson/scm/subversion/taglib
            http://fisheye4.cenqua.com/changelog/hudson/?cs=25559
            Log:
            refactored the part of the UI to a tag in anticipatoin of JENKINS-2053.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/plugins/subversion/pom.xml
            trunk/hudson/plugins/subversion/src/main/java/hudson/scm/SubversionSCM.java
            trunk/hudson/plugins/subversion/src/main/java/hudson/scm/SubversionTagAction.java
            trunk/hudson/plugins/subversion/src/main/java/hudson/scm/UserProvidedCredential.java
            trunk/hudson/plugins/subversion/src/main/resources/hudson/scm/SubversionTagAction/help-credential.html
            trunk/hudson/plugins/subversion/src/main/resources/hudson/scm/SubversionTagAction/tagForm.jelly
            http://fisheye4.cenqua.com/changelog/hudson/?cs=25725
            Log:
            [FIXED JENKINS-2053] Expanded the UI to allow the user to specify a one-time credential for tagging. This will be in 1.9.

            idlysphere idlysphere added a comment -

            "Use alternate credential for tagging" is not working.

            I think that the following patch fix this.

            Index: src/main/resources/hudson/scm/SubversionTagAction/tagForm.jelly
            ===================================================================
            --- src/main/resources/hudson/scm/SubversionTagAction/tagForm.jelly	(revision 27458)
            +++ src/main/resources/hudson/scm/SubversionTagAction/tagForm.jelly	(working copy)
            @@ -101,7 +101,7 @@
                             <div class="textarea-handle"/>
                           </td>
                         </tr>
            -            <f:optionalBlock field="credential" title="${%Use alternate credential for tagging}">
            +            <f:optionalBlock name="credential" title="${%Use alternate credential for tagging}">
                           <f:block>
                             <table style="width:100%">
                               <x:enterCredential xmlns:x="/hudson/scm/subversion" />
            
            abayer Andrew Bayer added a comment -

            Can't reproduce this - I got it working just fine on trunk as of 3/20/10.


              People

              • Assignee:
                Unassigned
                Reporter:
                drulli Ulli Hafner
              • Votes:
                15 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: