Details

    • Similar Issues:

      Description

      Not sure is this a bug or not.
      In this chart http://localhost/monitoring?part=graph&graph=httpSessions, I see the HTTP session count is increased from 0 to 100,110,120... after restart. But in this page http://localhost/monitoring?part=sessions I only see less than 10 sessions.
      I think the data of the 2 charts should be aligned, is it correct?

      Btw, for the HTTP session is always increased, I think it's an issue and just post in community to get help http://jenkins-ci.361315.n4.nabble.com/HTTP-session-increases-and-out-of-memory-td4680122.html

        Attachments

          Issue Links

            Activity

            dennys Dennys Hsieh created issue -
            schniedergers Klaus Schniedergers added a comment -

            I see the same issue in our 1.539 instance.
            What's worse is that I see a significant increase in sessions before the service becomes unresponsive and has to be restarted.

            Currently we have ~200 sessions in the counter, but only ~12 sessions listed.

            samxiao Sam Xiao made changes -
            Field Original Value New Value
            Component/s core [ 15593 ]
            evernat evernat made changes -
            Assignee evernat [ evernat ]
            evernat evernat added a comment -

            The issue is probably related to the change from Winstone to Jetty8, in Jenkins v1.535:
            http://jenkins-ci.org/changelog#v1.535

            I have reproduced the issue locally after a load test (the sessions chart shows a high number of sessions, but there are only one session in the list of sessions).
            In the report http://localhost/monitoring?part=heaphisto or in a heap dump, I can also see that there is exactly the same high number of instances of org.eclipse.jetty.server.session.HashedSession existing in memory, as in the chart.

            The cause can be related to the following jetty bug (fixed in Jetty 9.1, which is later than Jetty 8 used by Jenkins):
            https://bugs.eclipse.org/bugs/show_bug.cgi?id=413019

            So the invalidated http sessions are not garbage collected, there is a small memory leak in the monitoring plugin, and the sessions chart is "not right".
            I will fix that, with a workaround for the jetty bug.

            dennys Dennys Hsieh added a comment -

            Since this is a Jetty's bug, does it mean that Jenkins has memory leak issue?

            evernat evernat added a comment -

            @Dennys
            No, just the monitoring plugin

            evernat evernat made changes -
            Link This issue is related to JENKINS-20640 [ JENKINS-20640 ]
            evernat evernat added a comment - - edited

            attached chart from related issue JENKINS-20640

            evernat evernat made changes -
            Attachment http_session.png [ 24732 ]
            evernat evernat added a comment -

            This is now fixed in the monitoring plugin v1.48, which was just published.
            The monitoring plugin v1.48 should be available in the update center of your Jenkins, or from http://mirrors.jenkins-ci.org/plugins/monitoring/, in a few hours (24h max?).

            evernat evernat made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            dennys Dennys Hsieh added a comment -

            After upgrading to 1.48, it's fixed, thanks.

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 152057 ] JNJira + In-Review [ 194191 ]

              People

              • Assignee:
                evernat evernat
                Reporter:
                dennys Dennys Hsieh
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: