Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20757

jenkins startup dies quickly ostensibly due to maven problem in 1.540 and 1.541

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Win 2008 server R2 standard
    • Similar Issues:

      Description

      Jenkins v1.539 is ok. Failures began in 1.540 and continue in 1.541; ergo, newer Jenkins versions are unusable.

      INFO: Listed all plugins
      Nov 25, 2013 8:52:53 AM jenkins.InitReactorRunner$1 onAttained
      INFO: Prepared all plugins
      Nov 25, 2013 8:52:53 AM jenkins.InitReactorRunner$1 onAttained
      INFO: Started all plugins
      Nov 25, 2013 8:52:53 AM jenkins.InitReactorRunner$1 onAttained
      INFO: Augmented all extensions
      Nov 25, 2013 8:52:55 AM hudson.ExtensionFinder$Sezpoz scout
      WARNING: Failed to scout hudson.maven.MavenModuleSet
      java.lang.NoClassDefFoundError: hudson/tasks/JavadocArchiver
      at hudson.maven.MavenModuleSet$DescriptorImpl.<clinit>(MavenModuleSet.java:1320)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Unknown Source)
      at hudson.ExtensionFinder$Sezpoz.scout(ExtensionFinder.java:680)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:310)
      at hudson.ExtensionList.load(ExtensionList.java:295)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:309)
      at hudson.ExtensionList.load(ExtensionList.java:295)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      at hudson.ExtensionList.get(ExtensionList.java:153)
      at jenkins.plugins.htmlaudio.app.HtmlAudioNotifierPlugin.getComponent(HtmlAudioNotifierPlugin.java:66)
      at jenkins.plugins.htmlaudio.app.HtmlAudioNotifierPlugin.initializePlugin(HtmlAudioNotifierPlugin.java:46)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:105)
      at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:169)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:896)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.ClassNotFoundException: hudson.tasks.JavadocArchiver
      at org.apache.tools.ant.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      at org.apache.tools.ant.AntClassLoader.findClass(AntClassLoader.java:1315)
      at org.apache.tools.ant.AntClassLoader.loadClass(AntClassLoader.java:1068)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      ... 27 more

      Nov 25, 2013 8:52:59 AM hudson.ExtensionFinder$GuiceFinder instantiate
      WARNING: Failed to load hudson.maven.MavenModuleSet
      java.lang.InstantiationException: java.lang.NoClassDefFoundError: Could not initialize class hudson.maven.MavenModuleSet$DescriptorImpl
      at net.java.sezpoz.IndexItem.instance(IndexItem.java:193)
      at hudson.ExtensionFinder$GuiceFinder.instantiate(ExtensionFinder.java:355)
      at hudson.ExtensionFinder$GuiceFinder.access$700(ExtensionFinder.java:234)
      at hudson.ExtensionFinder$GuiceFinder$SezpozModule$1.get(ExtensionFinder.java:531)
      at com.google.inject.internal.ProviderInternalFactory.provision(ProviderInternalFactory.java:86)
      at com.google.inject.internal.InternalFactoryToInitializableAdapter.provision(InternalFactoryToInitializableAdapter.java:55)
      at com.google.inject.internal.ProviderInternalFactory.circularGet(ProviderInternalFactory.java:66)
      at com.google.inject.internal.InternalFactoryToInitializableAdapter.get(InternalFactoryToInitializableAdapter.java:47)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter$1.call(ProviderToInternalFactoryAdapter.java:46)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1058)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:40)
      at com.google.inject.Scopes$1$1.get(Scopes.java:65)
      at hudson.ExtensionFinder$GuiceFinder$FaultTolerantScope$1.get(ExtensionFinder.java:429)
      at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:41)
      at com.google.inject.internal.InjectorImpl$3$1.call(InjectorImpl.java:1005)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1051)
      at com.google.inject.internal.InjectorImpl$3.get(InjectorImpl.java:1001)
      at hudson.ExtensionFinder$GuiceFinder._find(ExtensionFinder.java:391)
      at hudson.ExtensionFinder$GuiceFinder.find(ExtensionFinder.java:382)
      at hudson.ExtensionFinder._find(ExtensionFinder.java:151)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:316)
      at hudson.ExtensionList.load(ExtensionList.java:295)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at jenkins.model.Jenkins.getDescriptor(Jenkins.java:1160)
      at hudson.plugins.git.GitTool.onLoaded(GitTool.java:95)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:105)
      at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:169)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:896)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.NoClassDefFoundError: Could not initialize class hudson.maven.MavenModuleSet$DescriptorImpl
      at hudson.maven.MavenModuleSet.<clinit>(MavenModuleSet.java:1217)
      at sun.misc.Unsafe.ensureClassInitialized(Native Method)
      at sun.reflect.UnsafeFieldAccessorFactory.newFieldAccessor(Unknown Source)
      at sun.reflect.ReflectionFactory.newFieldAccessor(Unknown Source)
      at java.lang.reflect.Field.acquireFieldAccessor(Unknown Source)
      at java.lang.reflect.Field.getFieldAccessor(Unknown Source)
      at java.lang.reflect.Field.get(Unknown Source)
      at net.java.sezpoz.IndexItem.instance(IndexItem.java:185)
      ... 38 more

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            This is unrelated to maven (it's just warnings after all), and instead the Windows crasher introduced in 1.540 and fixed with 1.542.

            https://issues.jenkins-ci.org/browse/JENKINS-20630

            Should be fixed in 1.542.

            wlb warren brown added a comment -

            Correct. There is nothing else.

            danielbeck Daniel Beck added a comment -

            That stack trace only shows warnings. Is there nothing else?


              People

              • Assignee:
                Unassigned
                Reporter:
                wlb warren brown
              • Votes:
                2 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: