Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20787

BUILD_USER_ID is not set in Maven build execution triggered by release:perform

    Details

    • Similar Issues:

      Description

      When doing a release for a Maven build project (using the m2release plugin), the build user vars gets screwed up in the Maven build during the Maven build execution triggered by release:perform.
      BUILD_USER is set to the user id ('kaha14' for example). BUILD_USER_ID is not set. BUILD_USER_FIRST_NAME is set to the same as BUILD_USER and BUILD_USER_LAST_NAME is not set (probably because BUILD_USER is just one word).

        Attachments

          Issue Links

            Activity

            ahammar Anders Hammar created issue -
            lshatzer Larry Shatzer, Jr. made changes -
            Field Original Value New Value
            Component/s m2release [ 15621 ]
            Component/s release [ 15622 ]
            ahammar Anders Hammar made changes -
            Link This issue depends on JENKINS-20791 [ JENKINS-20791 ]
            ahammar Anders Hammar made changes -
            Link This issue is related to JENKINS-20797 [ JENKINS-20797 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 152598 ] JNJira + In-Review [ 178260 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                ahammar Anders Hammar
              • Votes:
                2 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated: