Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20894

When the upstream build fails,it won't show cppcheck test results

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: cppcheck-plugin
    • Labels:
      None
    • Environment:
      jenkins 1.480.3 cppcheck 1.14
    • Similar Issues:

      Description

      I have a upstream job A, In this job,I use trigger builds on other project in build step to call cppcheck1 job which execute cppcheck,call bb as well. Job bb will fail and cppcheck1 will succeed .However it looks like due to the upstream job A will be marked failure,cppcheck results will not be published . This is not expected

        Attachments

          Activity

          mixalturek Michal Turek added a comment -

          I'm unable to reproduce the issue. I'm sorry, it is quite difficult to understand your description, my scenario is:

          • Execute clean installation of Jenkins 1.532.2.
            export JENKINS_HOME=home && java -jar jenkins.war
            
          • Install Cppcheck Plugin 1.4.
          • Install Parameterized Trigger plugin 2.23 ("Trigger/call builds on other projects" in "Add build step" menu).
          • Create project "bb" that always fails (command "false" in Execute shell).
          • Create project "jenkins1" that successfully executes Cppcheck and publishes the report.
          • Create project "A" that triggers "jenkins1" and "bb" according to your screenshot.
          • Build project "A".
          • Project "bb" failed as expected.
          • Project "A" failed as expected (because "bb" failed).
          • Project "jenkins1" is successfully built as expected.
          • The Cppcheck report was published and it is accessible in "jenkins1" as expected.

          Can you provide additional information what I do different than you, please?

          mixalturek Michal Turek added a comment -

          Rejecting for now, please reopen if you can provide any additional information.


            People

            • Assignee:
              mixalturek Michal Turek
              Reporter:
              lx_wpp Lynn Lin
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: