Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: checkstyle-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Error while serving http://localhost:8081/hudson/view/MOBILE/job/mo
      bile-doc-HEAD/317/checkstyleResult/new
      java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:103)
      at org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:384)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:440)
      at org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:385)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:440)
      at org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:385)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:440)
      at org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:264)
      at
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:31)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:440)
      at org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:264)
      at
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:31)
      at org.kohsuke.stapler.Stapler.invoke(Stapler.java:440)
      at org.kohsuke.stapler.Stapler.service(Stapler.java:121)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:804)
      at
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at hudson.util.PluginServletFilter.doFilter(PluginServletFilter.java:30)
      at
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:52)
      at
      hudson.security.UnwrapSecurityExceptionFilter.doFilter(UnwrapSecurityExceptionFilter.java:28)
      at
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      at
      org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:168)
      at
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      at
      org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)
      at
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      at
      org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:272)
      at
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      at
      org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter(RememberMeProcessingFilter.java:142)
      at
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      at
      org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:174)
      at
      hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
      at
      hudson.security.HttpSessionContextIntegrationFilter2.doFilter(HttpSessionContextIntegrationFilter2.java:42)
      at
      hudson.security.ChainedServletFilter.doFilter(ChainedServletFilter.java:44)
      at hudson.security.HudsonFilter.doFilter(HudsonFilter.java:85)
      at
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at
      org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:97)
      at
      org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at
      org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:177)
      at
      org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:180)
      at
      org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:434)
      at
      org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
      at
      org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:133)
      at
      org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:104)
      at
      org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:111)
      at
      org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:241)
      at
      org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:859)
      at
      org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:580)
      at org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1513)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.NullPointerException
      at
      hudson.plugins.checkstyle.util.model.AnnotationContainer.addAnnotations(AnnotationContainer.java:276)
      at
      hudson.plugins.checkstyle.util.AbstractAnnotationsDetail.<init>(AbstractAnnotationsDetail.java:44)
      at
      hudson.plugins.checkstyle.util.NewWarningsDetail.<init>(NewWarningsDetail.java:29)
      at
      hudson.plugins.checkstyle.util.DetailBuilder.createTrendDetails(DetailBuilder.java:46)
      at
      hudson.plugins.checkstyle.CheckStyleResult.getDynamic(CheckStyleResult.java:454)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

        Attachments

          Activity

          drulli Ulli Hafner added a comment -

          Seems that the result is already disposed by the garbage collector.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : drulli
          Path:
          trunk/hudson/plugins/checkstyle/src/main/java/hudson/plugins/checkstyle/util/AnnotationsBuildResult.java
          trunk/hudson/plugins/findbugs/src/main/java/hudson/plugins/findbugs/util/AnnotationsBuildResult.java
          trunk/hudson/plugins/pmd/src/main/java/hudson/plugins/pmd/util/AnnotationsBuildResult.java
          trunk/hudson/plugins/tasks/src/main/java/hudson/plugins/tasks/util/AnnotationsBuildResult.java
          trunk/hudson/plugins/warnings/src/main/java/hudson/plugins/warnings/util/AnnotationsBuildResult.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=11007
          Log:
          [FIXED JENKINS-2093] Read annotations of current and previous build in one step to avoid that garbage collector already disposes the first set.


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              tspengler tspengler
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: