Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20954

NPE from MailSender.createEmptyMail

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: mailer-plugin
    • Labels:
      None
    • Environment:
      Centos 6.4/Tomcat 7.42
    • Similar Issues:

      Description

      Hello,

      When I create a maven build it does not save the email recipients. I do not have any email plugins installed.

      At the end of the build it does a npe:

      FATAL: null
      java.lang.NullPointerException
      at java.util.StringTokenizer.<init>(StringTokenizer.java:199)
      at java.util.StringTokenizer.<init>(StringTokenizer.java:236)
      at hudson.tasks.MailSender.createEmptyMail(MailSender.java:326)
      at hudson.tasks.MailSender.createBackToNormalMail(MailSender.java:175)
      at hudson.tasks.MailSender.getMail(MailSender.java:166)
      at hudson.tasks.MailSender.execute(MailSender.java:100)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.cleanUp(MavenModuleSetBuild.java:1038)
      at hudson.model.Run.execute(Run.java:1723)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:509)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:231)

        Attachments

          Issue Links

            Activity

            jomu78 Joern Muehlencord added a comment -

            retested using 1.7 & Jenkins 1.544. Still maven 2/3 project do not store the email address. NPE is solved as empty email is detected correclty.
            Reproduceable by:

            • select project
            • edit configuration
            • add email address
            • edit configuration (again) --> emailaddress is gone
            jglick Jesse Glick added a comment -

            One bug at a time please. Please file a separate bug in the maven-plugin component and link it to this one.

            gregh3269 Greg Huber added a comment -

            Sorry, I am a bit confused, the original issue was that the email recipient would not save, and as a result there was a npe. What has been fixed now on this, the email recipient not saving or the npe?

            Cheers Greg.

            jomu78 Joern Muehlencord added a comment - - edited
            jomu78 Joern Muehlencord added a comment -

            NPE is fixed, not be able to save is still open (even it was the orinal header of the bug)
            With 1.7 sending emails is still broken but at least you do not receive an ugly error because of the blank email list.


              People

              • Assignee:
                Unassigned
                Reporter:
                gregh3269 Greg Huber
              • Votes:
                9 Vote for this issue
                Watchers:
                15 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: