Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20970

Unexpected close of a file stream

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      https://github.com/jenkinsci/weblogic-deployer-plugin/commit/981fc3eacd1979833ff2674fbea1c410bd626f2b

      It seems like the log file stream is closed a bit too early (before calling the
      deploy() method which then uses that stream). As a result, my deployment log file is empty
      and Jenkins prints the following stacktrace:

      11:07:04 java.io.IOException: Stream Closed
      11:07:04 at java.io.FileOutputStream.writeBytes(Native Method)
      11:07:04 at java.io.FileOutputStream.write(FileOutputStream.java:325)
      11:07:04 at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.undeploy(DeploymentTaskServiceImpl.java:284)
      11:07:04 at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.perform(DeploymentTaskServiceImpl.java:182)
      11:07:04 at org.jenkinsci.plugins.deploy.weblogic.WeblogicDeploymentPlugin.perform(WeblogicDeploymentPlugin.java:236)
      11:07:04 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      11:07:04 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:785)
      11:07:04 at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:757)
      11:07:04 at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:1020)
      11:07:04 at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:706)
      11:07:04 at hudson.model.Run.execute(Run.java:1702)
      11:07:04 at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:509)
      11:07:04 at hudson.model.ResourceController.execute(ResourceController.java:88)
      11:07:04 at hudson.model.Executor.run(Executor.java:231)
      11:07:04 ERROR: [WeblogicDeploymentPlugin] - Failed to deploy.

        Attachments

          Activity

          Hide
          ystefanov Yos Stef added a comment -

          Hello, Raphael

          Just to let you know, the fix works perfect in 2.9.1 !
          Thank you for the very fast reaction. Happy holidays

          Show
          ystefanov Yos Stef added a comment - Hello, Raphael Just to let you know, the fix works perfect in 2.9.1 ! Thank you for the very fast reaction. Happy holidays
          Hide
          raphc Raphael CHAUMIER added a comment -

          I released 2.9.1 which should fixed this regression.

          Show
          raphc Raphael CHAUMIER added a comment - I released 2.9.1 which should fixed this regression.
          Hide
          ystefanov Yos Stef added a comment -

          I have the same problem. All settings seem to be correct. WebLogic 11 (10.3.6) , Jenkins v1.543 , Weblogic Deployment Plugin 2.9 . JDK 1.7 ... I will provide with any info needed. Here is the plugin configuration :

          <?xml version="1.0" encoding="UTF-8"?>
          <config xmlns="http://org.jenkinsci.plugins/WeblogicDeploymentPlugin"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xsi:schemaLocation="http://org.jenkinsci.plugins/WeblogicDeploymentPlugin plugin-configuration.xsd">
          <weblogic-targets>
          <weblogic-target>

          <name>WebLogic11</name>
          <host>http://dev.company.com</host>
          <port>6001</port>
          <login>user</login>
          <password>user1111</password>
          <authMode>BY_LOGIN</authMode>

          <!-- -->
          </weblogic-target>
          </weblogic-targets>
          </config>

          Show
          ystefanov Yos Stef added a comment - I have the same problem. All settings seem to be correct. WebLogic 11 (10.3.6) , Jenkins v1.543 , Weblogic Deployment Plugin 2.9 . JDK 1.7 ... I will provide with any info needed. Here is the plugin configuration : <?xml version="1.0" encoding="UTF-8"?> <config xmlns="http://org.jenkinsci.plugins/WeblogicDeploymentPlugin" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://org.jenkinsci.plugins/WeblogicDeploymentPlugin plugin-configuration.xsd"> <weblogic-targets> <weblogic-target> <name>WebLogic11</name> <host> http://dev.company.com </host> <port>6001</port> <login>user</login> <password>user1111</password> <authMode>BY_LOGIN</authMode> <!-- --> </weblogic-target> </weblogic-targets> </config>

            People

            • Assignee:
              raphc Raphael CHAUMIER
              Reporter:
              raphc Raphael CHAUMIER
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: