Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20986

Unexpected termination of slave channel during "Archive the artifacts"

    Details

    • Similar Issues:

      Description

      Hello,

      I am currently receiving this Error during builds.

      SEVERE: I/O error in channel <CHANNEL_NAME>
      java.io.IOException: Unexpected termination of the channel
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:50)
      Caused by: java.io.EOFException
      at java.io.ObjectInputStream$BlockDataInputStream.peekByte(ObjectInputStream.java:2553)
      at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1296)
      at java.io.ObjectInputStream.readObject(ObjectInputStream.java:350)
      at hudson.remoting.Command.readFrom(Command.java:92)
      at hudson.remoting.ClassicCommandTransport.read(ClassicCommandTransport.java:71)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)

      This happens after the "Multi Configuration" Build ran successfully when Jenkins tries to archive the artifacts.

      The slave channel automatically reconnects but the build job is stuck indefinitely at the "archive artifacts" stage and has to be manually aborted.
      The slave channel in Question is a HP-UX B.11.31 ia64.

      A couple of important things to note:
      1) This slave can also be used by an older jenkins instance running 1.431.
      2) The Job being used was migrated from this old jenkins instance
      3) The Job is a multi config job and builds successfully on all other architectures (SuSe, Solaris, Red-Hat)
      4) The job runs successfully on the older jenkins instance!
      5) There are no network issues responsible for the termination of the channel
      6) Java issues on the slave are also not likely as I mentioned the exact same slave can be used without incident from the other jenkins instance

      Of course, I used a different FS root so that each jenkins instance could set up their own slave.jars etc. But other than that, the slave works without problems when building this job using the old jenkins instance but it will always fail on this slave during the "archive artifacts" stage of the build.

        Attachments

          Issue Links

            Activity

            Hide
            oleg_nenashev Oleg Nenashev added a comment - - edited

            @Mac
            Seems that the issue duplicates https://issues.jenkins-ci.org/browse/JENKINS-15682

            Show
            oleg_nenashev Oleg Nenashev added a comment - - edited @Mac Seems that the issue duplicates https://issues.jenkins-ci.org/browse/JENKINS-15682
            Hide
            danielbeck Daniel Beck added a comment -

            No response to Oleg's comment in 7+ months, so assuming this is in fact a duplicate and linking to JENKINS-15682.

            Show
            danielbeck Daniel Beck added a comment - No response to Oleg's comment in 7+ months, so assuming this is in fact a duplicate and linking to JENKINS-15682 .

              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                maccer Mac Cer
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: