Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21098

VM crash with no information in jenkins log

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
    • Environment:
      vm_info: OpenJDK 64-Bit Server VM (20.0-b12) for linux-amd64 JRE (1.6.0_24-b24), built on Oct 31 2013 07:52:48 by "mockbuild" with gcc 4.1.2 20080704 (Red Hat 4.1.2-54)
    • Similar Issues:

      Description

      Hello.

      Jenkins has been crashing after one day or two days up routinely for the past year or so. I don't have the version handy for when this started. I'm currently using 1.543

      I'm attaching the latest jvm crash report. The last three look the same and it seems to crash during SAM polling.

      Is this a known issue or is there something you can recommend for me to work around this?

      Thanks.

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          The RPM installer sets up a logrotate script that periodically sends a signal (SIGABRT?) to the Jenkins Java process. Try to see whether that's the cause by manually recreating that and/or removing the logrotate script.

          If so, probably a bug in your JVM implementation.

          oleg_nenashev Oleg Nenashev added a comment -

          Java 1.6u24 is outdated.
          The issue should be reproduced on newer ones.


            People

            • Assignee:
              Unassigned
              Reporter:
              billbrown Bill Brown
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: