Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21258

Graphical artefacts in the trend graphs

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: sloccount-plugin
    • Labels:
      None
    • Environment:
      Bug in the code logic.
    • Similar Issues:

      Description

      If a language newly appears/disappears in/from SLOCCount report the trend graphs will contain graphical artifacts. The issue is visible mainly in the delta trend but it is (and always was) present in the absolute one too. The code doesn't consider that currently processed build may contain different languages than the previous and next ones.

      See the attached screenshots.

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Michal Turek
          Path:
          src/main/java/hudson/plugins/sloccount/ReportSummary.java
          src/main/java/hudson/plugins/sloccount/SloccountChartBuilder.java
          http://jenkins-ci.org/commit/sloccount-plugin/b214b258df66a1671271be14a24d0391ea8c57aa
          Log:
          JENKINS-21258 Graphical artefacts in the trend graphs

          • If a language newly appears/disappears in/from SLOCCount report the trend graphs will contain graphical artifacts. The issue is visible mainly in the delta trend but it is (and always was) present in the absolute one too. The code doesn't consider that currently processed build may contain different languages than the previous and next ones.
          • The issue fixed by adding zero or negative lines count for all known languages that are not present in the particular build but may be present in the previous or next ones.

            People

            • Assignee:
              mixalturek Michal Turek
              Reporter:
              mixalturek Michal Turek
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: