Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21279

java.lang.IllegalArgumentException: Null value not allowed as an environment variable: POM_PACKAGING

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      CentoOS 5 Linux master, assorted slaves
    • Similar Issues:

      Description

      SEVERE: Failed to record SCM polling for hudson.maven.MavenModuleSet@1118b490[testing-parent-trunk]
      java.lang.IllegalArgumentException: Null value not allowed as an environment variable: POM_PACKAGING
              at hudson.EnvVars.put(EnvVars.java:356)
              at hudson.maven.MavenModuleSetBuild.getEnvironment(MavenModuleSetBuild.java:194)
              at hudson.scm.SubversionSCM.compareRemoteRevisionWith(SubversionSCM.java:1235)
              at hudson.scm.SCM._compareRemoteRevisionWith(SCM.java:356)
              at hudson.scm.SCM.poll(SCM.java:373)
              at hudson.model.AbstractProject._poll(AbstractProject.java:1584)
              at hudson.model.AbstractProject.poll(AbstractProject.java:1493)
              at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:456)
              at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:485)
              at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
              at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
              at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
              at java.util.concurrent.FutureTask.run(FutureTask.java:138)
              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
              at java.lang.Thread.run(Thread.java:619)
      

        Attachments

          Issue Links

            Activity

            jsullivan8z Jeremy Sullivan added a comment -

            No, neither. There is a dropdown menu by the module name that will allow you to delete it.

            For the record, I tried to delete the workspace. It had no effect.

            tony_sweeney Tony Sweeney added a comment - - edited

            OK, I had to fiddle a bit, as the delete dropdown menu item gave me a 403 bad crumb error, but if instead I selected the configure dropdown for the module, there was an option to delete the module in the left hand menu, which worked fine. If you then list the modules belonging to the build, the module still shows as present, but the status ball is greyed out. Running the build causes the module to be reinstantiated. This is a pretty painful workround, as I have many dozens of Maven builds each with a handful or two of modules. Worse, I can't actually validate it in my test system, since I can't reproduce the error there. But if it works it's better than nothing...

            hubaer Marco Huber added a comment -

            We have the same problem after installing Jenkins V 1.549. We copied our project from Hudson 1.398 into the new Jenkins instance, but all exisiting configurations break with this error.

            aromu Aapo Romu added a comment -

            I was able to fix the problem by deleting rm -rf jenkins/jobs/project_name/modules/* and then restarting Jenkins. You should be able to script that easily if you have a lot of projects

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Kohsuke Kawaguchi
            Path:
            src/main/java/hudson/maven/MavenModuleSetBuild.java
            http://jenkins-ci.org/commit/maven-plugin/4bdfef299f07fabedcb43b902d5ddfc05d62f8cd
            Log:
            [FIXED JENKINS-21279]

            Not sure packaging doesn't defeault to "jar", which seems to be the default, but being defensive.


              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                tony_sweeney Tony Sweeney
              • Votes:
                1 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: