Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2153

findbugs ParserResult attempts to alter UnmodifiableCollection

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: findbugs-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      After upgrading to latest static analysis plugins on hudson 1.238...

      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] null
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      java.lang.UnsupportedOperationException
      at java.util.Collections$UnmodifiableCollection.addAll(Collections.java:1028)
      at hudson.plugins.findbugs.util.ParserResult.addModules(ParserResult.java:202)
      at
      hudson.plugins.findbugs.util.AbstractResultAction.addModule(AbstractResultAction.java:286)
      at
      hudson.plugins.findbugs.util.AbstractResultAction.createAggregatedResult(AbstractResultAction.java:265)
      at
      hudson.plugins.findbugs.MavenFindBugsResultAction.update(MavenFindBugsResultAction.java:89)
      at hudson.maven.MavenModuleSetBuild.notifyModuleBuild(MavenModuleSetBuild.java:250)
      at hudson.maven.MavenBuild$ProxyImpl2.end(MavenBuild.java:357)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:240)
      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:223)
      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:183)
      at hudson.remoting.UserRequest.perform(UserRequest.java:69)
      at hudson.remoting.UserRequest.perform(UserRequest.java:23)
      at hudson.remoting.Request$2.run(Request.java:206)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)

        Attachments

          Issue Links

            Activity

            drulli Ulli Hafner added a comment -

            Fixed in 2.11.

            drulli Ulli Hafner added a comment -
                • Issue 2162 has been marked as a duplicate of this issue. ***
            francisdb francisdb added a comment -
                • Issue 2157 has been marked as a duplicate of this issue. ***
            francisdb francisdb added a comment -

            when should this 2.11. version be released to the plugin repo?


              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                robdale robdale
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: