Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2158

If Maven runs the test suite multiple times the Test Result Trend graph and Stats are increased with each run.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      My team uses the Clover2 plugin for Maven. Due to the structure of Clover, the
      testing suite is run twice. The test result graph and failure listing displayed
      in Hudson have values that are double what they should be. This is an
      inaccurate representation of the data. The Surefire plugin reports it correctly
      however.

        Attachments

          Issue Links

            Activity

            abonderud abonderud created issue -
            jweden jweden added a comment -

            This may be a duplicate of bug 1557.

            evernat evernat made changes -
            Field Original Value New Value
            Link This issue duplicates JENKINS-1557 [ JENKINS-1557 ]
            evernat evernat added a comment -

            This issue is certainly a duplicate of JENKINS-1557 and it was certainly fixed with JENKINS-1557.

            Please reopen this issue if it was not the case.

            evernat evernat made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Duplicate [ 3 ]
            ircbot Jenkins IRC Bot made changes -
            Component/s maven-plugin [ 16033 ]
            Component/s maven2 [ 15487 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 132231 ] JNJira + In-Review [ 186520 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                abonderud abonderud
              • Votes:
                1 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: