Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21643

Jenkins Plugin for WebSphere Deployer Not deploying to Websphere AS 7 ( Remote deployment)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      client
      ---------
      Jenkins on Tomcat v7.0.0 with latest plugin


      remote server
      --------
      Windows 7
      Websphere ND V7.0.0.21
    • Similar Issues:

      Description

      Hi there

      Most helpful if anyone can help on this. The plugin SSL connection and location of deployment WAR works but it fails to deploy to a remote WAS instance. There is no entry in the log files on the server or any evidence of installables that have been copied over to the remote server. The only msg is a plugin error error message:

      Connecting to IBM WebSphere Application Server...
      The following artifacts will be deployed in this order...
      -------------------------------------------
      XJourney.war
      -------------------------------------------
      Generating EAR For New Artifact: XJourney
      Deploying New 'XJourney' to IBM WebSphere Application Server
      Error deploying to IBM WebSphere Application Server: org.jenkinsci.plugins.websphere.services.deployment.DeploymentServiceException: Failed to install artifact: Failure uploading archive to server
      at org.jenkinsci.plugins.websphere.services.deployment.WebSphereDeploymentService.installArtifact(WebSphereDeploymentService.java:167)
      at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.deployArtifact(WebSphereDeployerPlugin.java:193)
      at org.jenkinsci.plugins.websphere_deployer.WebSphereDeployerPlugin.perform(WebSphereDeployerPlugin.java:171)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:776)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(MavenModuleSetBuild.java:1007)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:726)
      at hudson.model.Run.execute(Run.java:1628)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:506)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:247)

      Build step 'Deploy To IBM WebSphere Application Server' changed build result to FAILURE
      Finished: FAILURE

        Attachments

          Activity

          joselaureano Jose Laureano added a comment -

          Greg Peters Michael Nothhard Were you guys able to release a fix for this? Thank you for the work.

          ashwaniraj Ashwani Raj added a comment - - edited

          I just wanted to share one more thing. I am using latest version of Jenkins and 8.5.5.5 version of WAS server.

          swetha644 swetha sreeramoju added a comment -

          Even I am facing the same issue. I have done all the configurations, able to telent the server with SOAP connector and getting successful message in Jenkins. But facing problem While deploying.

          gpeters Greg Peters added a comment -

          Fixed in Beta v1.3. Please test and validate by installing this plugin version manually.

          gpeters Greg Peters added a comment -

          Closing, Duplicate of JENKINS-31450. This is not a bug, rather it's an issue with mismatched DNS/IP setting in jenkins job + SSL DNS name from the admin console.


            People

            • Assignee:
              gpeters Greg Peters
              Reporter:
              kal kal
            • Votes:
              4 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: