Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21787

"use all the publishers from this project" is not triggering a new build

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Labels:
      None
    • Environment:
      Template Project plugin version: 1.4
      Jenkins Version: 1.550
      OS: Windows 7
      Java Version: 1.7.0_40
    • Similar Issues:

      Description

      Hi,

      We are facing problems with template project plugin. "use all the publishers from this project" is not triggering a new build.

      Below are the steps to reproduce this issue.

      1. Install Template Project Plugin(version: 1.4) on Jenkins(version: 1.550).

      2. Create Job_A, Job_B and Job_C.

      3. In Job_A configuration, Under Post build action -> Add post-build action -> Use publishers from another project, enter "Job_B" for Template Project.

      4. In Job_B configuration, Under Post build action -> Add post-build action -> Build Other Projects ->enter "Job_C" for Projects to Build.

      With this configuration, if I build Job_B, build for Job_C will be triggered.

      Using Template Project plugin, we have used Job_B as template for Job_A.

      If I trigger Job_A, it pulls the publisher configuration from Job_B and it is supposed to trigger Job_C.

      But if I build Job_A, Job_C is not at all triggered. But other post build actions like email, Java doc is working fine.

      Seems the problem is only in building other projects.

      Is there already a fix for this problem? Could you please help us to fix this?

      Thanks,
      Sampath.

        Attachments

          Activity

          oleg_nenashev Oleg Nenashev added a comment -

          As designed.
          Use Parameterized Trigger Plugin if you want to trigger a new build

          williambernardet William Bernardet added a comment -

          The fix for JENKINS-23710 will also covert this issue.


            People

            • Assignee:
              huybrechts huybrechts
              Reporter:
              sampath_selenium1 sampath kumar
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: