Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2184

Junit tests with same name not handled correctly

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: junit-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      If you have multiple Junit tests with the same name, for example, if you run the
      same tests on multiple platforms, then links to the results of those tests are
      not correct.

      To recreate, you can do the following:

      Take the xml output of a junit test, and copy it to two directories in a hudson
      build for processing. For example: tests/windows/myjunittest.xml and
      tests/linux/myjunittest.xml

      Change the value of <system-err> to something so there is a difference in the
      tests. for example <system-err>This is the linux test</system-err>

      After the build and junit results processing, Hudson will say that 2 tests were
      run. But, if you click on the results for both tests, both will be exactly the
      same. The URLs to the test results are both equal, so it appears there is no
      way for Hudson to differentiate if the user wants to see the results of the
      first or second test.

        Attachments

          Issue Links

            Activity

            smithgcovert smithgcovert added a comment -

            This has been reported again, as bug 2604. That bug should probably be marked
            as a duplicate of this bug.

            Searching for open junit bugs, it appears that several of the open bugs are
            actually related to this problem.

            Has there been any progress on this issue? Can I supply any information that
            could help to resolve this?

            Thanks
            Greg

            drulli Ulli Hafner added a comment -
                • Issue 2310 has been marked as a duplicate of this issue. ***
            jglick Jesse Glick added a comment -

            Should be fixed in new releases. Verification would be appreciated.

                • This issue has been marked as a duplicate of 2988 ***

              People

              • Assignee:
                Unassigned
                Reporter:
                smithgcovert smithgcovert
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: