Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21870

'Build-Node-Column: Performance decreases when number of slaves increase

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Environment:
    • Similar Issues:

      Description

      With increasing number of slaves the performance of the build node column display seems to decrease significantly.
      In our setup, after increasing number of Slave from 7 to 18, all views that are showing the "Last Build Node" column took more than double time to show.

      For example a view containing approximately 70 jobs took about 15 seconds to show with 7 slaves and 55 seconds with 18 slaves.

      Monitoring the CPU load (Prcoess Explorer and Jenkins Melody Monitor Plugin) shows a fully loaded CPU-core for the request.

      After completely removing the "Last Build Node" column, the same view appears in less than a second.

      The number of jobs obviously also has an impact (i.e. a view with 20 jobs and "Last Build Node" column shows in about 5 seconds). But the impact of the number of Slaves seems to be much higher.

      I didn't test if the number of Offline versuse Online slaves has an impact.

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          Seems to be unrelated to core.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Fred G
          Path:
          src/main/java/jenkins/plugins/extracolumns/LastBuildNodeColumn.java
          src/main/resources/jenkins/plugins/extracolumns/LastBuildNodeColumn/column.jelly
          src/main/resources/jenkins/plugins/extracolumns/LastBuildNodeColumn/columnHeader.jelly
          src/main/resources/jenkins/plugins/extracolumns/LastBuildNodeColumn/columnHeader_de.properties
          src/main/resources/jenkins/plugins/extracolumns/LastBuildNodeColumn/config.jelly
          src/main/resources/jenkins/plugins/extracolumns/LastBuildNodeColumn/config_de.properties
          src/main/resources/jenkins/plugins/extracolumns/Messages.properties
          src/main/resources/jenkins/plugins/extracolumns/Messages_de.properties
          http://jenkins-ci.org/commit/extra-columns-plugin/3a95245926f7abb3075f2a63e413480121f70f5d
          Log:
          Add LastBuildNodeColumn

          Replaces Build Node Column Plugin by Takahisa Wada, includes potential
          fix for JENKINS-21870

          fredg Fred G added a comment -

          I've migrated the last build node column to the Extra Columns Plugin (version 1.16+) and added a potential fix for this issue. Please test and report back if you still see a performance issue with the new column.

          klou Kurt added a comment -

          Thanks for the fix!
          I've added Build-Node columns to plenty of our (sectioned) views. In the meantime we've also have increased number of slaves to >30.
          No impact to performance can be noticed at all any more. The views showing up instantaneously just as without build node column.

          fredg Fred G added a comment -

          Thanks for the feedback. Glad to hear that the issue is fixed.


            People

            • Assignee:
              klou Kurt
              Reporter:
              klou Kurt
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: