Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21958

ArtifactManager introduces regression with publishing symbolic links.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Environment:
    • Similar Issues:

      Description

      I have observed a regression issue with the introduction of the new ArtifactManager (https://github.com/jenkinsci/jenkins/commit/e1eea67bb2fa1a356492e91313d84a523f441b34 - https://issues.jenkins-ci.org/browse/JENKINS-17236 ).

      I have pinpointed the issue and saw it was introduced in jenkins 1.532 (as in it works perfectly in 1.531, but fails in 1.532 and above, including the 1.532.2 LTS version).

      My particular use case is that the result of our build creates a symlink which points to the final artifact (the final artifact as stored on disk has a timestamp/build number in its name). However with the introduction of the new ArtifactManager the artifacts which are identified using symlinks no longer get published.

      Steps to reproduce:

      • Create a new job
      • Add a shell build step
        rm -rf folder
        mkdir folder 
        echo "bla" > folder/artifact
        ln -sf ./artifact folder/link
        
      • Add a 'Archive the Artifacts' post-build action and in the Files to archive text box enter
        folder/link
        

      Expected behavior (as implemented/verified) on jenkins 1.524 - 1.531:

      • The build succeeds
      • The 'Last Successful Artifacts' mentions:
        link 4B
        

      Actual behavior (as implemented/verified) on jenkins 1.532 - 1.552, including LTS:

      • The build succeeds
      • The 'Last Successful Artifacts' mentions nothing.

      (for reference the build output:

      Started by user anonymous
      Building on master in workspace /home/jenkins/jenkins/jobs/brossel_edb/workspace
      [workspace] $ /bin/sh -xe /tmp/hudson1352860404870483249.sh
      + rm -rf folder
      + mkdir folder
      + echo bla
      + ln -sf ./artifact folder/link
      Archiving artifacts
      Finished: SUCCESS
      

      )

      An additional sidenote is that the ArtifactDeployer plugin (version 0.28) is doing its job properly, another indication that the way symlinks are resolved/dealt with has likely changed due the introduction of the new ArtifactManager.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jglick Jesse Glick
                Reporter:
                eliedebrauwer Elie De Brauwer
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: