Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2201

first toplevel directory gets tagged directly into base directoy of new tag

    Details

    • Type: Patch
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: svn-tag-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      As far as I can see, svn-tag plugin's behaviour is strange, because if
      you set the projects SCM for example to trunk and after a successful
      build are going to tag it, all the modules which were checked out of the
      SCM become subfolders in the tag, except for the first one.

      e.g.

      somerep

      • trunk
      • basic
      • folder1
      • folder2
      • basic-profile
      • folder3
      • folder4
      • basic-stuff
      • ....
      • tags
      • tag1
      • tag2

      then i'm building for example the basic & basic-profile projects, the
      build is successful and I'm going to tag it.
      this is the result:

      somerep

      • trunk
      • basic
      • folder1
      • folder2
      • basic-profile
      • folder3
      • folder4
      • basic-stuff
      • ....
      • tags
      • tag1
      • tag2
      • tag3
      • basic-profile
      • folder3
        -folder4
      • folder1
      • folder2

      the first project to be checked out by the SCM is always deployed in the
      base-directory of the tag, not in it's specific subfolders. the
      following projects are then deployed in their specific subfolders. i
      made a workaround, by checking out a "dummy"-project first, which is
      empty, i can successfully tag the build. but if i have to check out that
      build again - the "dummy" project of course is missing.
      I hope you can see that this problem causes me to be not able to change
      a tag or branch and build it, and if this is successful, lets me tag it
      or branch it as i wish.

        Attachments

          Activity

          k2nakamura k2nakamura added a comment -

          Svnkit doesn't provide the option to equivalent with "-parent" in the command
          line, but I implemented a workaround and now svn-tag should create the
          intermediate directories. Please upgrade to version 1.7 and verify if the issue
          is fixed.

          Thank you for your patience,

          weichselbaumer weichselbaumer added a comment -

          Creating the intermediate directory now works - but somehow the last part of the
          tag directory is treated as a nomral intermediate directory - meaning that this
          also gets created in the first place - therefore I am ending up with the folder
          that I want to have directly in the tag directory being generated as another
          subdirectory...

          Looks like this:

          Tagging build in Subversion
          moduleLocation: Remote ->https://xxx:8443/svn/yyy/trunk/basic
          Tag Base URL: 'https://xxx:8443/svn/yyy/tags/wc_083000_000682/basic'.
          There was no old tag at https://xxx:8443/svn/yyy/tags/wc_083000_000682/basic.
          Tagged as Revision 32586

          moduleLocation: Remote ->https://xxx:8443/svn/yyy/trunk/basic-db
          Tag Base URL: 'https://xxx:8443/svn/yyy/tags/wc_083000_000682/basic-db'.
          There was no old tag at https://xxx:8443/svn/yyy/tags/wc_083000_000682/basic-db.
          Tagged as Revision 32584

          This gets my a tag that looks like this:
          https://xxx:8443/svn/yyy/tags/wc_083000_000682/basic/basic/$CONTENT
          https://xxx:8443/svn/yyy/tags/wc_083000_000682/basic-db/basic-db/$CONTENT

          I guess it looks like this, because the tag directory (wc_083000_000682) is
          generated and the directory I want to have in this tag directory is also being
          generated. Therefore I am ending up with this "../directory/directory" tag.

          I think you need to create all intermediate directories of the
          "parsedTagBaseURL" except for the last part - which is the directory that is
          supposed to be tagged.

          Once again I have to say: thank you for your efforts!

          weichselbaumer weichselbaumer added a comment -

          done..

          weichselbaumer weichselbaumer added a comment -

          don't know what happened here... wanted to close another issue and set this one
          to fixed. it isn't...

          I'll copy-paste my last comment for this issue in here, hope no one get's confused.

          Once again: Issue is not fixed..

          Creating the intermediate directory now works - but somehow the last part of the
          tag directory is treated as a nomral intermediate directory - meaning that this
          also gets created in the first place - therefore I am ending up with the folder
          that I want to have directly in the tag directory being generated as another
          subdirectory...

          Looks like this:

          Tagging build in Subversion
          moduleLocation: Remote ->https://xxx:8443/svn/yyy/trunk/basic
          Tag Base URL: 'https://xxx:8443/svn/yyy/tags/wc_083000_000682/basic'.
          There was no old tag at https://xxx:8443/svn/yyy/tags/wc_083000_000682/basic.
          Tagged as Revision 32586

          moduleLocation: Remote ->https://xxx:8443/svn/yyy/trunk/basic-db
          Tag Base URL: 'https://xxx:8443/svn/yyy/tags/wc_083000_000682/basic-db'.
          There was no old tag at https://xxx:8443/svn/yyy/tags/wc_083000_000682/basic-db.
          Tagged as Revision 32584

          This gets my a tag that looks like this:
          https://xxx:8443/svn/yyy/tags/wc_083000_000682/basic/basic/$CONTENT
          https://xxx:8443/svn/yyy/tags/wc_083000_000682/basic-db/basic-db/$CONTENT

          I guess it looks like this, because the tag directory (wc_083000_000682) is
          generated and the directory I want to have in this tag directory is also being
          generated. Therefore I am ending up with this "../directory/directory" tag.

          I think you need to create all intermediate directories of the
          "parsedTagBaseURL" except for the last part - which is the directory that is
          supposed to be tagged.

          Once again I have to say: thank you for your efforts!

          k2nakamura k2nakamura added a comment -

          My test case showed the problem, but I overlooked. Fixed in 1.8.


            People

            • Assignee:
              k2nakamura k2nakamura
              Reporter:
              weichselbaumer weichselbaumer
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: